phpVMS has an /importer authorization bypass causing full database wipe
The advisory, in context
Security Advisory: Unauthenticated Access to Legacy Import Feature
Severity: Critical Affected versions: phpVMS 7.x (up to 7.0.5) Fixed in: v7.0.6 Component: Legacy importer
Summary
A critical vulnerability in phpVMS 7.x allowed unauthenticated access to a legacy import feature. Although this feature is deprecated, parts of it remained accessible and operational.
Impact
A remote attacker could trigger internal processes that modify or delete application data, potentially resulting in:
- Data loss
- Service disruption
No authentication was required.
Remediation
- Update immediately to the latest patched version
- If unable to update:
- The release link has instructions on how to fix it (it's a one-line fix to comment out the routes)
Affected Versions
- Affected: phpVMS 7.x ≤ 7.0.5
- Not affected: phpVMS >= 7.0.6, v8 (feature removed from public access)
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
Earlier releases before 7.0.6
Fixed in 7.0.6
12 explicitly affected versions
7.0.0, 7.0.0-beta.2, 7.0.0-beta.3, 7.0.0-beta.4, 7.0.0-beta.5, 7.0.1, 7.0.2, 7.0.3, 7.0.4, 7.0.5, v7.0.0-alpha2, v7.0.0-beta
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "7.0.6"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"7.0.0",
"7.0.0-beta.2",
"7.0.0-beta.3",
"7.0.0-beta.4",
"7.0.0-beta.5",
"7.0.1",
"7.0.2",
"7.0.3",
"7.0.4",
"7.0.5",
"v7.0.0-alpha2",
"v7.0.0-beta"
]
}References
- https://github.com/phpvms/phpvms/security/advisories/GHSA-fv26-4939-62fh
- https://nvd.nist.gov/vuln/detail/CVE-2026-42569
- https://github.com/phpvms/phpvms/commit/f59ba8e0e8fc25c60c3faf14e526cfd49df3f7dc
- https://github.com/phpvms/phpvms
- https://github.com/phpvms/phpvms/releases/tag/7.0.6
- https://github.com/phpvms/phpvms/releases/tag/7.0.7