Improper escaping of command arguments on Windows leading to command injection
The advisory, in context
Impact
Windows users running Composer to install untrusted dependencies are affected and should definitely upgrade for safety. Other OSs and WSL are not affected.
Patches
1.10.23 and 2.1.9 fix the issue
Workarounds
None
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
Earlier releases before 1.10.23
Fixed in 1.10.23
91 explicitly affected versions
1.0.0, 1.0.0-alpha1, 1.0.0-alpha10, 1.0.0-alpha11, 1.0.0-alpha2, 1.0.0-alpha3, 1.0.0-alpha4, 1.0.0-alpha5, 1.0.0-alpha6, 1.0.0-alpha7, 1.0.0-alpha8, 1.0.0-alpha9, 1.0.0-beta1, 1.0.0-beta2, 1.0.1, 1.0.2, 1.0.3, 1.1.0, 1.1.0-RC, 1.1.1, 1.1.2, 1.1.3, 1.10.0, 1.10.0-RC, 1.10.1, 1.10.10, 1.10.11, 1.10.12, 1.10.13, 1.10.14, 1.10.15, 1.10.16, 1.10.17, 1.10.18, 1.10.19, 1.10.2, 1.10.20, 1.10.21, 1.10.22, 1.10.3, 1.10.4, 1.10.5, 1.10.6, 1.10.7, 1.10.8, 1.10.9, 1.2.0, 1.2.0-RC, 1.2.1, 1.2.2, 1.2.3, 1.2.4, 1.3.0, 1.3.0-RC, 1.3.1, 1.3.2, 1.3.3, 1.4.0, 1.4.1, 1.4.2, 1.4.3, 1.5.0, 1.5.1, 1.5.2, 1.5.3, 1.5.4, 1.5.5, 1.5.6, 1.6.0, 1.6.0-RC, 1.6.1, 1.6.2, 1.6.3, 1.6.4, 1.6.5, 1.7.0, 1.7.0-RC, 1.7.1, 1.7.2, 1.7.3, 1.8.0, 1.8.1, 1.8.2, 1.8.3, 1.8.4, 1.8.5, 1.8.6, 1.9.0, 1.9.1, 1.9.2, 1.9.3
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "1.10.23"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"1.0.0",
"1.0.0-alpha1",
"1.0.0-alpha10",
"1.0.0-alpha11",
"1.0.0-alpha2",
"1.0.0-alpha3",
"1.0.0-alpha4",
"1.0.0-alpha5",
"1.0.0-alpha6",
"1.0.0-alpha7",
"1.0.0-alpha8",
"1.0.0-alpha9",
"1.0.0-beta1",
"1.0.0-beta2",
"1.0.1",
"1.0.2",
"1.0.3",
"1.1.0",
"1.1.0-RC",
"1.1.1",
"1.1.2",
"1.1.3",
"1.10.0",
"1.10.0-RC",
"1.10.1",
"1.10.10",
"1.10.11",
"1.10.12",
"1.10.13",
"1.10.14",
"1.10.15",
"1.10.16",
"1.10.17",
"1.10.18",
"1.10.19",
"1.10.2",
"1.10.20",
"1.10.21",
"1.10.22",
"1.10.3",
"1.10.4",
"1.10.5",
"1.10.6",
"1.10.7",
"1.10.8",
"1.10.9",
"1.2.0",
"1.2.0-RC",
"1.2.1",
"1.2.2",
"1.2.3",
"1.2.4",
"1.3.0",
"1.3.0-RC",
"1.3.1",
"1.3.2",
"1.3.3",
"1.4.0",
"1.4.1",
"1.4.2",
"1.4.3",
"1.5.0",
"1.5.1",
"1.5.2",
"1.5.3",
"1.5.4",
"1.5.5",
"1.5.6",
"1.6.0",
"1.6.0-RC",
"1.6.1",
"1.6.2",
"1.6.3",
"1.6.4",
"1.6.5",
"1.7.0",
"1.7.0-RC",
"1.7.1",
"1.7.2",
"1.7.3",
"1.8.0",
"1.8.1",
"1.8.2",
"1.8.3",
"1.8.4",
"1.8.5",
"1.8.6",
"1.9.0",
"1.9.1",
"1.9.2",
"1.9.3"
]
}From 2.0.0-alpha1 before 2.1.9
Fixed in 2.1.9
30 explicitly affected versions
2.0.0, 2.0.0-RC1, 2.0.0-RC2, 2.0.0-alpha1, 2.0.0-alpha2, 2.0.0-alpha3, 2.0.1, 2.0.10, 2.0.11, 2.0.12, 2.0.13, 2.0.14, 2.0.2, 2.0.3, 2.0.4, 2.0.5, 2.0.6, 2.0.7, 2.0.8, 2.0.9, 2.1.0, 2.1.0-RC1, 2.1.1, 2.1.2, 2.1.3, 2.1.4, 2.1.5, 2.1.6, 2.1.7, 2.1.8
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "2.0.0-alpha1"
},
{
"fixed": "2.1.9"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"2.0.0",
"2.0.0-RC1",
"2.0.0-RC2",
"2.0.0-alpha1",
"2.0.0-alpha2",
"2.0.0-alpha3",
"2.0.1",
"2.0.10",
"2.0.11",
"2.0.12",
"2.0.13",
"2.0.14",
"2.0.2",
"2.0.3",
"2.0.4",
"2.0.5",
"2.0.6",
"2.0.7",
"2.0.8",
"2.0.9",
"2.1.0",
"2.1.0-RC1",
"2.1.1",
"2.1.2",
"2.1.3",
"2.1.4",
"2.1.5",
"2.1.6",
"2.1.7",
"2.1.8"
]
}References
- https://github.com/composer/composer/security/advisories/GHSA-frqg-7g38-6gcf
- https://nvd.nist.gov/vuln/detail/CVE-2021-41116
- https://github.com/composer/composer/commit/ca5e2f8d505fd3bfac6f7c85b82f2740becbc0aa
- https://github.com/FriendsOfPHP/security-advisories/blob/master/composer/composer/CVE-2021-41116.yaml
- https://github.com/composer/composer
- https://www.sonarsource.com/blog/securing-developer-tools-package-managers
- https://www.tenable.com/security/tns-2022-09