GHSA-fr34-mx6j-vpxhhigh8.1
ImpressPages CMS eval injection vulnerability
The advisory, in context
Eval injection vulnerability in ip_cms/modules/standard/content_management/actions.php in ImpressPages CMS 1.0.12 and possibly other versons before 1.0.13 allows remote attackers to execute arbitrary code via the cm_group parameter.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
impresspages/impresspages Packagist
Ecosystem versions
Earlier releases before 1.0.13
Fixed in 1.0.13
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "1.0.13"
}
],
"type": "ECOSYSTEM"
}
],
"versions": []
}References
- https://nvd.nist.gov/vuln/detail/CVE-2011-4932
- https://github.com/impresspages/ImpressPages
- https://web.archive.org/web/20120726055617/http://www.securityfocus.com/bid/49798
- https://web.archive.org/web/20120726081336/http://www.impresspages.org/news/impresspages-1-0-13-security-release
- http://seclists.org/bugtraq/2011/Sep/156
- http://www.openwall.com/lists/oss-security/2012/01/15/9
- http://www.openwall.com/lists/oss-security/2012/01/18/12