GIVE YOUR AGENT THE EVIDENCE

Set up in your agent.

One prompt to get started. Paste it into your coding agent to connect cve.new through MCP and bring vulnerability context into your workflow.

Your agent needs remote MCP support and access to https://cve.new/mcp.

Read the setup guide

GIVE YOUR AGENT THE EVIDENCE

Investigate in your agent.

Turn this advisory into a focused investigation. Ask your agent to check your project’s versions, explain the evidence, and suggest a compatible fix.

Your agent needs remote MCP support and access to https://cve.new/mcp.

Read the setup guide

GHSA-fq6h-4g8v-qqvmmedium6.1

CKEditor4 Cross-site Scripting vulnerability caused by incorrect CDATA detection

Check your stack

The advisory, in context

Affected packages

The vulnerability has been discovered in the core HTML parsing module and may affect all editor instances that:

Impact

A potential vulnerability has been discovered in CKEditor 4 HTML processing core module. The vulnerability allowed to inject malformed HTML content bypassing Advanced Content Filtering mechanism, which could result in executing JavaScript code. An attacker could abuse faulty CDATA content detection and use it to prepare an intentional attack on the editor. It affects all users using the CKEditor 4 at version < 4.24.0-lts.

Patches

The problem has been recognized and patched. The fix will be available in version 4.24.0-lts.

For more information

Email us at security@cksource.com if you have any questions or comments about this advisory.

Acknowledgements

The CKEditor 4 team would like to thank Michal Frýba from ALEF NULA for recognizing and reporting this vulnerability.

Affected packages

Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.

Semantic versions

Earlier releases before 4.24.0-lts

Fixed in 4.24.0-lts

View affected-version evidence
{
  "ranges": [
    {
      "events": [
        {
          "introduced": "0"
        },
        {
          "fixed": "4.24.0-lts"
        }
      ],
      "type": "SEMVER"
    }
  ],
  "versions": []
}
Ecosystem versions

Earlier releases before 4.24.0

Fixed in 4.24.0

66 explicitly affected versions

4.10.0, 4.10.1, 4.11.0, 4.11.1, 4.11.2, 4.11.3, 4.11.4, 4.12.0, 4.12.1, 4.13.0, 4.13.1, 4.14.0, 4.14.1, 4.15.0, 4.15.1, 4.16.0, 4.16.1, 4.16.2, 4.17.0, 4.17.1, 4.17.2, 4.18.0, 4.19.0, 4.19.1, 4.20.0, 4.20.1, 4.20.2, 4.21.0, 4.22.0, 4.22.1, 4.23.0, 4.3.3, 4.3.4, 4.3.5, 4.4.0, 4.4.1, 4.4.2, 4.4.3, 4.4.4, 4.4.5, 4.4.6, 4.4.7, 4.4.8, 4.5.0, 4.5.1, 4.5.10, 4.5.11, 4.5.2, 4.5.3, 4.5.4, 4.5.5, 4.5.6, 4.5.7, 4.5.8, 4.5.9, 4.6.0, 4.6.1, 4.6.2, 4.7.0, 4.7.1, 4.7.2, 4.7.3, 4.8.0, 4.9.0, 4.9.1, 4.9.2

View affected-version evidence
{
  "ranges": [
    {
      "events": [
        {
          "introduced": "0"
        },
        {
          "fixed": "4.24.0"
        }
      ],
      "type": "ECOSYSTEM"
    }
  ],
  "versions": [
    "4.10.0",
    "4.10.1",
    "4.11.0",
    "4.11.1",
    "4.11.2",
    "4.11.3",
    "4.11.4",
    "4.12.0",
    "4.12.1",
    "4.13.0",
    "4.13.1",
    "4.14.0",
    "4.14.1",
    "4.15.0",
    "4.15.1",
    "4.16.0",
    "4.16.1",
    "4.16.2",
    "4.17.0",
    "4.17.1",
    "4.17.2",
    "4.18.0",
    "4.19.0",
    "4.19.1",
    "4.20.0",
    "4.20.1",
    "4.20.2",
    "4.21.0",
    "4.22.0",
    "4.22.1",
    "4.23.0",
    "4.3.3",
    "4.3.4",
    "4.3.5",
    "4.4.0",
    "4.4.1",
    "4.4.2",
    "4.4.3",
    "4.4.4",
    "4.4.5",
    "4.4.6",
    "4.4.7",
    "4.4.8",
    "4.5.0",
    "4.5.1",
    "4.5.10",
    "4.5.11",
    "4.5.2",
    "4.5.3",
    "4.5.4",
    "4.5.5",
    "4.5.6",
    "4.5.7",
    "4.5.8",
    "4.5.9",
    "4.6.0",
    "4.6.1",
    "4.6.2",
    "4.7.0",
    "4.7.1",
    "4.7.2",
    "4.7.3",
    "4.8.0",
    "4.9.0",
    "4.9.1",
    "4.9.2"
  ]
}

References