GHSA-fpxg-5x79-43rmmedium6.1
MODX Revolution allows XSS via document resources
The advisory, in context
MODX Revolution through v2.7.0-pl allows XSS via a document resource (such as pagetitle), which is mishandled during an Update action, a Quick Edit action, or the viewing of manager logs.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
modx/revolution Packagist
Ecosystem versions
Earlier releases before 2.7.1-pl
Fixed in 2.7.1-pl
1 explicitly affected versions
v2.7.0-pl
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "2.7.1-pl"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v2.7.0-pl"
]
}