Auth0 laravel-auth0 SDK has Insufficient Entropy in Cookie Encryption
The advisory, in context
Impact
In applications built with the Auth0 PHP SDK, cookies are encrypted with insufficient entropy, which may result in threat actors brute-forcing the encryption key and forging session cookies.
Am I Affected?
You are affected if you meet the following preconditions:
- Applications using laravel-auth0 SDK, versions between 7.0.0 and 7.20.0
- Laravel-auth0 SDK using the Auth0-PHP SDK versions between 8.0.0 to 8.18.0.
Resolution
Upgrade Auth0/laravel-auth0 to version 7.21.0 or greater.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
From 7.0.0 before 7.21.0
Fixed in 7.21.0
29 explicitly affected versions
7.0.0, 7.0.1, 7.1.0, 7.10.0, 7.10.1, 7.11.0, 7.12.0, 7.13.0, 7.14.0, 7.15.0, 7.16.0, 7.17.0, 7.18.0, 7.19.0, 7.2.0, 7.2.1, 7.2.2, 7.20.0, 7.3.0, 7.4.0, 7.5.0, 7.5.1, 7.5.2, 7.6.0, 7.7.0, 7.8.0, 7.8.1, 7.9.0, 7.9.1
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "7.0.0"
},
{
"fixed": "7.21.0"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"7.0.0",
"7.0.1",
"7.1.0",
"7.10.0",
"7.10.1",
"7.11.0",
"7.12.0",
"7.13.0",
"7.14.0",
"7.15.0",
"7.16.0",
"7.17.0",
"7.18.0",
"7.19.0",
"7.2.0",
"7.2.1",
"7.2.2",
"7.20.0",
"7.3.0",
"7.4.0",
"7.5.0",
"7.5.1",
"7.5.2",
"7.6.0",
"7.7.0",
"7.8.0",
"7.8.1",
"7.9.0",
"7.9.1"
]
}