GHSA-fgrx-4637-fcf5medium
fuel/core Crypt encryption compromised.
No CVE assignedCheck your stack
The advisory, in context
In fuel/core versions pior to 1.8.1, with the right knowledge, code, and GPU calculation power, Crypt encryption can be broken in minutes.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
fuel/core Packagist
Ecosystem versions
Earlier releases before 1.8.1
Fixed in 1.8.1
5 explicitly affected versions
1.8.0, 1.8.0.1, 1.8.0.2, 1.8.0.3, 1.8.0.4
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "1.8.1"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"1.8.0",
"1.8.0.1",
"1.8.0.2",
"1.8.0.3",
"1.8.0.4"
]
}