Pterodactyl vulnerable to 2FA Sniffing
The advisory, in context
Pterodactyl version 0.7.13 and lower - 2FA Sniffing
Users who have enabled 2FA protections on their account can unintentionally have their account's existence sniffed by malicious users who enter random credentials into the login fields.
Impact
Users who have enabled 2FA protections on their account can unintentionally have their account's existence sniffed by malicious users who enter random credentials into the login fields.
A logical mistake was made when the original code was written that would wait to verify the user's password until they had provided 2FA credentials if it was enabled on their account. However, because of this you could enter a bad password for a known email and determine if the account exists if you got redirected to a 2FA page.
For more information
If you have any questions or comments about this advisory please react out on Discord or email dane@[project name].io.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
Earlier releases before 0.7.14
Fixed in 0.7.14
46 explicitly affected versions
v0.1.0-beta, v0.1.1-beta, v0.1.2-beta, v0.2.0-beta, v0.3.0-beta, v0.4.0-beta, v0.4.1-beta, v0.5.0, v0.5.0-rc.1, v0.5.0-rc.2, v0.5.1, v0.5.2, v0.5.3, v0.5.4, v0.5.5, v0.5.6, v0.5.7, v0.6.0, v0.6.0-beta.1, v0.6.0-beta.2, v0.6.0-beta.2.1, v0.6.0-rc.1, v0.6.1, v0.6.2, v0.6.3, v0.6.4, v0.7.0, v0.7.0-beta.1, v0.7.0-beta.2, v0.7.0-beta.3, v0.7.0-beta.4, v0.7.0-rc.1, v0.7.0-rc.2, v0.7.1, v0.7.10, v0.7.11, v0.7.12, v0.7.13, v0.7.2, v0.7.3, v0.7.4, v0.7.5, v0.7.6, v0.7.7, v0.7.8, v0.7.9
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "0.7.14"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v0.1.0-beta",
"v0.1.1-beta",
"v0.1.2-beta",
"v0.2.0-beta",
"v0.3.0-beta",
"v0.4.0-beta",
"v0.4.1-beta",
"v0.5.0",
"v0.5.0-rc.1",
"v0.5.0-rc.2",
"v0.5.1",
"v0.5.2",
"v0.5.3",
"v0.5.4",
"v0.5.5",
"v0.5.6",
"v0.5.7",
"v0.6.0",
"v0.6.0-beta.1",
"v0.6.0-beta.2",
"v0.6.0-beta.2.1",
"v0.6.0-rc.1",
"v0.6.1",
"v0.6.2",
"v0.6.3",
"v0.6.4",
"v0.7.0",
"v0.7.0-beta.1",
"v0.7.0-beta.2",
"v0.7.0-beta.3",
"v0.7.0-beta.4",
"v0.7.0-rc.1",
"v0.7.0-rc.2",
"v0.7.1",
"v0.7.10",
"v0.7.11",
"v0.7.12",
"v0.7.13",
"v0.7.2",
"v0.7.3",
"v0.7.4",
"v0.7.5",
"v0.7.6",
"v0.7.7",
"v0.7.8",
"v0.7.9"
]
}References
- https://github.com/pterodactyl/panel/security/advisories/GHSA-vcm9-hx3q-qwj8
- https://nvd.nist.gov/vuln/detail/CVE-2019-1020002
- https://github.com/pterodactyl/panel/commit/092e7e79fff858ee026608c7dbccab165a67526f
- https://github.com/pterodactyl/panel
- https://github.com/pterodactyl/panel/releases/tag/v0.7.14