GHSA-ffcm-vhcw-p32rmedium6.1
TYPO3 Backend component Cross-site scripting (XSS) vulnerability
The advisory, in context
Cross-site scripting (XSS) vulnerability in the Backend component in TYPO3 6.2.x before 6.2.19 allows remote attackers to inject arbitrary web script or HTML via the module parameter when creating a bookmark.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
typo3/cms Packagist
Ecosystem versions
From 6.2.0 before 6.2.19
Fixed in 6.2.19
20 explicitly affected versions
6.2.0, 6.2.1, 6.2.10, 6.2.10-rc1, 6.2.11, 6.2.12, 6.2.13, 6.2.14, 6.2.15, 6.2.16, 6.2.17, 6.2.18, 6.2.2, 6.2.3, 6.2.4, 6.2.5, 6.2.6, 6.2.7, 6.2.8, 6.2.9
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "6.2.0"
},
{
"fixed": "6.2.19"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"6.2.0",
"6.2.1",
"6.2.10",
"6.2.10-rc1",
"6.2.11",
"6.2.12",
"6.2.13",
"6.2.14",
"6.2.15",
"6.2.16",
"6.2.17",
"6.2.18",
"6.2.2",
"6.2.3",
"6.2.4",
"6.2.5",
"6.2.6",
"6.2.7",
"6.2.8",
"6.2.9"
]
}References
- https://nvd.nist.gov/vuln/detail/CVE-2016-4056
- https://github.com/TYPO3/typo3
- https://labs.integrity.pt/advisories/cve-pending-stored-cross-site-scripting-in-typo3-bookmarks
- https://typo3.org/teams/security/security-bulletins/typo3-core/typo3-core-sa-2016-006
- http://www.openwall.com/lists/oss-security/2016/04/21/1