GIVE YOUR AGENT THE EVIDENCE

Set up in your agent.

One prompt to get started. Paste it into your coding agent to connect cve.new through MCP and bring vulnerability context into your workflow.

Your agent needs remote MCP support and access to https://cve.new/mcp.

Read the setup guide

GIVE YOUR AGENT THE EVIDENCE

Investigate in your agent.

Turn this advisory into a focused investigation. Ask your agent to check your project’s versions, explain the evidence, and suggest a compatible fix.

Your agent needs remote MCP support and access to https://cve.new/mcp.

Read the setup guide

Check your stack
GHSA-ff9r-ww9c-43x8high8.7

Statamic CMS vulnerable to privilege escalation via stored cross-site scripting

Impact

Stored XSS vulnerability in content titles allow authenticated users with content creation permissions to inject malicious JavaScript that executes when viewed by higher-privileged users.

Source excerpt · OSV
Applies when

Malicious user must have an account with control panel access and content creation permissions.

Affected packages

Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.

statamic/cms Packagist
Affected rangeRecorded fix
From 6.0.0 before 6.2.3Ecosystem versions6.2.3

Version evidence: OSV · GHSA-ff9r-ww9c-43x8

View original version evidence (5 explicit versions)

Original source description

Impact

Stored XSS vulnerability in content titles allow authenticated users with content creation permissions to inject malicious JavaScript that executes when viewed by higher-privileged users.

Malicious user must have an account with control panel access and content creation permissions.

This vulnerability can be exploited to allow super admin accounts to be created.

Patches

This has been fixed in 6.2.3.

References