phpMyAdmin SQL injection vulnerability
The advisory, in context
In phpMyAdmin 4.x before 4.9.5 and 5.x before 5.0.2, a SQL injection vulnerability was discovered where malicious code could be used to trigger an XSS attack through retrieving and displaying results (in tbl_get_field.php and libraries/classes/Display/Results.php). The attacker must be able to insert crafted data into certain database tables, which when retrieved (for instance, through the Browse tab) can trigger the XSS attack.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
From 3.4 before 4.9.5
Fixed in 4.9.5
45 explicitly affected versions
4.0.0, 4.0.1, 4.0.10, 4.0.10.1, 4.0.10.2, 4.0.10.3, 4.0.10.4, 4.0.10.5, 4.0.10.6, 4.0.10.7, 4.0.10.8, 4.0.10.9, 4.0.2, 4.0.3, 4.0.4, 4.0.4.1, 4.0.4.2, 4.0.5, 4.0.6, 4.0.7, 4.0.8, 4.0.9, 4.7.0, 4.7.1, 4.7.2, 4.7.3, 4.7.4, 4.7.5, 4.7.6, 4.7.7, 4.7.8, 4.7.9, 4.8.0, 4.8.0.1, 4.8.1, 4.8.2, 4.8.3, 4.8.4, 4.8.5, 4.9.0, 4.9.0.1, 4.9.1, 4.9.2, 4.9.3, 4.9.4
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "3.4"
},
{
"fixed": "4.9.5"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"4.0.0",
"4.0.1",
"4.0.10",
"4.0.10.1",
"4.0.10.2",
"4.0.10.3",
"4.0.10.4",
"4.0.10.5",
"4.0.10.6",
"4.0.10.7",
"4.0.10.8",
"4.0.10.9",
"4.0.2",
"4.0.3",
"4.0.4",
"4.0.4.1",
"4.0.4.2",
"4.0.5",
"4.0.6",
"4.0.7",
"4.0.8",
"4.0.9",
"4.7.0",
"4.7.1",
"4.7.2",
"4.7.3",
"4.7.4",
"4.7.5",
"4.7.6",
"4.7.7",
"4.7.8",
"4.7.9",
"4.8.0",
"4.8.0.1",
"4.8.1",
"4.8.2",
"4.8.3",
"4.8.4",
"4.8.5",
"4.9.0",
"4.9.0.1",
"4.9.1",
"4.9.2",
"4.9.3",
"4.9.4"
]
}From 5.0.0 before 5.0.2
Fixed in 5.0.2
3 explicitly affected versions
5.0.0, 5.0.0.1, 5.0.1
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "5.0.0"
},
{
"fixed": "5.0.2"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"5.0.0",
"5.0.0.1",
"5.0.1"
]
}References
- https://nvd.nist.gov/vuln/detail/CVE-2020-10803
- https://github.com/FriendsOfPHP/security-advisories/blob/master/phpmyadmin/phpmyadmin/CVE-2020-10803.yaml
- https://github.com/phpmyadmin/composer
- https://lists.debian.org/debian-lts-announce/2020/03/msg00028.html
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/AAVW3SUKWR5RF5LZ6SARCYOWBIFUIWOJ
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/BUG3IRITW2LUBGR5LSQMP7MVRTELHZJK
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/UZI6EQVRRIG252DY3MBT33BJVCSYDMQO
- https://www.phpmyadmin.net/security/PMASA-2020-4
- http://lists.opensuse.org/opensuse-security-announce/2020-03/msg00046.html
- http://lists.opensuse.org/opensuse-security-announce/2020-03/msg00050.html
- http://lists.opensuse.org/opensuse-security-announce/2020-11/msg00005.html