GIVE YOUR AGENT THE EVIDENCE

Set up in your agent.

One prompt to get started. Paste it into your coding agent to connect cve.new through MCP and bring vulnerability context into your workflow.

Your agent needs remote MCP support and access to https://cve.new/mcp.

Read the setup guide

GIVE YOUR AGENT THE EVIDENCE

Investigate in your agent.

Turn this advisory into a focused investigation. Ask your agent to check your project’s versions, explain the evidence, and suggest a compatible fix.

Your agent needs remote MCP support and access to https://cve.new/mcp.

Read the setup guide

GHSA-fcr8-6q7r-m4wgmedium5.2

Bypass of fix for CVE-2020-26231, Twig sandbox escape

Check your stack

The advisory, in context

Impact

A bypass of CVE-2020-26231 (fixed in 1.0.470/471 and 1.1.1) was discovered that has the same impact as CVE-2020-26231 & CVE-2020-15247:

An authenticated backend user with the cms.manage_pages, cms.manage_layouts, or cms.manage_partials permissions who would normally not be permitted to provide PHP code to be executed by the CMS due to cms.enableSafeMode being enabled is able to write specific Twig code to escape the Twig sandbox and execute arbitrary PHP.

This is not a problem for anyone that trusts their users with those permissions to normally write & manage PHP within the CMS by not having cms.enableSafeMode enabled, but would be a problem for anyone relying on cms.enableSafeMode to ensure that users with those permissions in production do not have access to write & execute arbitrary PHP.

Patches

Issue has been patched in Build 472 (v1.0.472) and v1.1.2.

Workarounds

Apply https://github.com/octobercms/october/commit/f63519ff1e8d375df30deba63156a2fc97aa9ee7 to your installation manually if unable to upgrade to Build 472 or v1.1.2.

References

Reported by ka1n4t

For more information

If you have any questions or comments about this advisory:

Threat assessment:

<img width="1108" alt="Screen Shot 2020-10-10 at 1 21 13 PM" src="https://user-images.githubusercontent.com/7253840/95663316-7de28b80-0afb-11eb-999d-a6526cf78709.png">

Affected packages

Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.

october/cms Packagist
Ecosystem versions

From 1.0.471 before 1.0.472

Fixed in 1.0.472

2 explicitly affected versions

1.0.471, v1.0.471

View affected-version evidence
{
  "ranges": [
    {
      "events": [
        {
          "introduced": "1.0.471"
        },
        {
          "fixed": "1.0.472"
        }
      ],
      "type": "ECOSYSTEM"
    }
  ],
  "versions": [
    "1.0.471",
    "v1.0.471"
  ]
}
october/cms Packagist
Ecosystem versions

From 1.1.1 before 1.1.2

Fixed in 1.1.2

2 explicitly affected versions

1.1.1, v1.1.1

View affected-version evidence
{
  "ranges": [
    {
      "events": [
        {
          "introduced": "1.1.1"
        },
        {
          "fixed": "1.1.2"
        }
      ],
      "type": "ECOSYSTEM"
    }
  ],
  "versions": [
    "1.1.1",
    "v1.1.1"
  ]
}

References