GHSA-f9hx-5jq4-fgjmhigh8.8
phpMyAdmin CSRF Vulnerability
The advisory, in context
phpMyAdmin versions 4.7.x (prior to 4.7.6.1/4.7.7) are vulnerable to a CSRF weakness. By deceiving a user to click on a crafted URL, it is possible to perform harmful database operations such as deleting records, dropping/truncating tables etc.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
phpmyadmin/phpmyadmin Packagist
Ecosystem versions
From 4.7 before 4.7.7
Fixed in 4.7.7
7 explicitly affected versions
4.7.0, 4.7.1, 4.7.2, 4.7.3, 4.7.4, 4.7.5, 4.7.6
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "4.7"
},
{
"fixed": "4.7.7"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"4.7.0",
"4.7.1",
"4.7.2",
"4.7.3",
"4.7.4",
"4.7.5",
"4.7.6"
]
}References
- https://nvd.nist.gov/vuln/detail/CVE-2017-1000499
- https://web.archive.org/web/20201208204518/http://www.securitytracker.com/id/1040163
- https://www.exploit-db.com/exploits/45284
- https://www.phpmyadmin.net/security/PMASA-2017-9
- http://cyberworldmirror.com/vulnerability-phpmyadmin-lets-attacker-perform-drop-table-single-click