Cobbler Improper Validation of Security Tokens
The advisory, in context
Cobbler version Verified as present in Cobbler versions 2.6.11+, but code inspection suggests at least 2.0.0+ or possibly even older versions may be vulnerable contains a Incorrect Access Control vulnerability in XMLRPC API (/cobbler_api) that can result in Privilege escalation, data manipulation or exfiltration, LDAP credential harvesting. This attack appear to be exploitable via "network connectivity". Taking advantage of improper validation of security tokens in API endpoints. Please note this is a different issue than CVE-2018-10931.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
Earlier releases before 3.0.0
Fixed in 3.0.0
1 explicitly affected versions
0.6.3-2
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "3.0.0"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"0.6.3-2"
]
}References
- https://nvd.nist.gov/vuln/detail/CVE-2018-1000226
- https://github.com/cobbler/cobbler/issues/1916
- https://github.com/cobbler/cobbler
- https://github.com/pypa/advisory-database/tree/main/vulns/cobbler/PYSEC-2026-315.yaml
- https://movermeyer.com/2018-08-02-privilege-escalation-exploits-in-cobblers-api
- https://pypi.org/project/cobbler