Zend Access Restriction Bypass
The advisory, in context
The (1) Zend_Ldap class in Zend before 1.12.9 and (2) Zend\Ldap component in Zend 2.x before 2.2.8 and 2.3.x before 2.3.3 allows remote attackers to bypass authentication via a password starting with a null byte, which triggers an unauthenticated bind.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
From 2.0.0 before 2.0.99
Fixed in 2.0.99
9 explicitly affected versions
2.0.0, 2.0.1, 2.0.2, 2.0.3, 2.0.4, 2.0.5, 2.0.6, 2.0.7, 2.0.8
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "2.0.0"
},
{
"fixed": "2.0.99"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"2.0.0",
"2.0.1",
"2.0.2",
"2.0.3",
"2.0.4",
"2.0.5",
"2.0.6",
"2.0.7",
"2.0.8"
]
}From 2.1.0 before 2.1.99
Fixed in 2.1.99
7 explicitly affected versions
2.1.0, 2.1.1, 2.1.2, 2.1.3, 2.1.4, 2.1.5, 2.1.6
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "2.1.0"
},
{
"fixed": "2.1.99"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"2.1.0",
"2.1.1",
"2.1.2",
"2.1.3",
"2.1.4",
"2.1.5",
"2.1.6"
]
}From 2.2.0 before 2.2.8
Fixed in 2.2.8
8 explicitly affected versions
2.2.0, 2.2.1, 2.2.2, 2.2.3, 2.2.4, 2.2.5, 2.2.6, 2.2.7
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "2.2.0"
},
{
"fixed": "2.2.8"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"2.2.0",
"2.2.1",
"2.2.2",
"2.2.3",
"2.2.4",
"2.2.5",
"2.2.6",
"2.2.7"
]
}From 2.3.0 before 2.3.3
Fixed in 2.3.3
3 explicitly affected versions
2.3.0, 2.3.1, 2.3.2
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "2.3.0"
},
{
"fixed": "2.3.3"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"2.3.0",
"2.3.1",
"2.3.2"
]
}From 1.12.0 before 1.12.9
Fixed in 1.12.9
9 explicitly affected versions
1.12.0, 1.12.1, 1.12.2, 1.12.3, 1.12.4, 1.12.5, 1.12.6, 1.12.7, 1.12.8
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "1.12.0"
},
{
"fixed": "1.12.9"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"1.12.0",
"1.12.1",
"1.12.2",
"1.12.3",
"1.12.4",
"1.12.5",
"1.12.6",
"1.12.7",
"1.12.8"
]
}References
- https://nvd.nist.gov/vuln/detail/CVE-2014-8088
- https://github.com/zendframework/zendframework/commit/a4222a6c1dc809f0f32fdafcd1ac4d583a075f2f
- https://exchange.xforce.ibmcloud.com/vulnerabilities/97038
- https://framework.zend.com/security/advisory/ZF2014-05
- https://github.com/FriendsOfPHP/security-advisories/blob/master/zendframework/zendframework/CVE-2014-8088.yaml
- https://github.com/FriendsOfPHP/security-advisories/blob/master/zendframework/zendframework1/CVE-2014-8088.yaml
- https://github.com/zendframework/zendframework
- http://lists.fedoraproject.org/pipermail/package-announce/2014-October/141070.html
- http://lists.fedoraproject.org/pipermail/package-announce/2014-October/141106.html
- http://www.debian.org/security/2015/dsa-3265
- http://www.openwall.com/lists/oss-security/2014/10/10/5
- http://www.oracle.com/technetwork/topics/security/bulletinjan2015-2370101.html
- http://www.securityfocus.com/bid/70378