GIVE YOUR AGENT THE EVIDENCE

Set up in your agent.

One prompt to get started. Paste it into your coding agent to connect cve.new through MCP and bring vulnerability context into your workflow.

Your agent needs remote MCP support and access to https://cve.new/mcp.

Read the setup guide

GIVE YOUR AGENT THE EVIDENCE

Investigate in your agent.

Turn this advisory into a focused investigation. Ask your agent to check your project’s versions, explain the evidence, and suggest a compatible fix.

Your agent needs remote MCP support and access to https://cve.new/mcp.

Read the setup guide

GHSA-f5c8-m5vw-rmgqmedium6.5

nova-toggle-5: Improper authorization on toggle endpoint allowed non-Nova users to modify boolean fields

Check your stack

The advisory, in context

Impact

In versions < 1.3.0, the toggle endpoint (POST /nova-vendor/nova-toggle/toggle/{resource}/{resourceId}) was protected only by web + auth:<guard> middleware. Any user authenticated on the configured guard could call the endpoint and flip boolean attributes on any Nova resource — including users who do not have access to Nova itself (for example, frontend customers sharing the web guard with the Nova admin area).

The endpoint also accepted an arbitrary attribute parameter, which meant a valid caller could toggle any boolean column on the underlying model — not just columns exposed as Toggle fields on the resource.

Patches

Fixed in 1.3.0:

  • The route is now protected by Nova's nova:api middleware, which enforces the viewNova gate.
  • The controller now checks the resource's authorizedToUpdate policy.
  • The controller only accepts attributes that are declared as a Toggle field on the resource and are not readonly in the current request context.

Workarounds

Users who cannot upgrade immediately can either remove the package or restrict access to the /nova-vendor/nova-toggle/toggle/* routes via an additional middleware in their application that enforces the viewNova gate.

Credits

nova-toggle-5 thanks Roberto Negro for the responsible disclosure.

Affected packages

Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.

Ecosystem versions

Earlier releases before 1.3.0

Fixed in 1.3.0

2 explicitly affected versions

v1.2.0, v1.2.1

View affected-version evidence
{
  "ranges": [
    {
      "events": [
        {
          "introduced": "0"
        },
        {
          "fixed": "1.3.0"
        }
      ],
      "type": "ECOSYSTEM"
    }
  ],
  "versions": [
    "v1.2.0",
    "v1.2.1"
  ]
}

References