Craft CMS Cross-site Scripting vulnerability
The advisory, in context
Craft CMS 4.2.0.1 is affected by Cross Site Scripting (XSS) in the file src/web/assets/cp/src/js/BaseElementSelectInput.js and in specific on the line label: elementInfo.label.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
From 4.0.0-RC1 before 4.2.1
Fixed in 4.2.1
24 explicitly affected versions
4.0.0, 4.0.0-RC1, 4.0.0-RC2, 4.0.0-RC3, 4.0.0.1, 4.0.1, 4.0.2, 4.0.3, 4.0.4, 4.0.5, 4.0.5.1, 4.0.5.2, 4.0.6, 4.1.0, 4.1.0.1, 4.1.0.2, 4.1.1, 4.1.2, 4.1.3, 4.1.4, 4.1.4.1, 4.2.0, 4.2.0.1, 4.2.0.2
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "4.0.0-RC1"
},
{
"fixed": "4.2.1"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"4.0.0",
"4.0.0-RC1",
"4.0.0-RC2",
"4.0.0-RC3",
"4.0.0.1",
"4.0.1",
"4.0.2",
"4.0.3",
"4.0.4",
"4.0.5",
"4.0.5.1",
"4.0.5.2",
"4.0.6",
"4.1.0",
"4.1.0.1",
"4.1.0.2",
"4.1.1",
"4.1.2",
"4.1.3",
"4.1.4",
"4.1.4.1",
"4.2.0",
"4.2.0.1",
"4.2.0.2"
]
}From 3.7.39 before 3.7.51
Fixed in 3.7.51
16 explicitly affected versions
3.7.39, 3.7.40, 3.7.40.1, 3.7.41, 3.7.42, 3.7.43, 3.7.44, 3.7.45, 3.7.45.1, 3.7.45.2, 3.7.46, 3.7.47, 3.7.47.1, 3.7.48, 3.7.49, 3.7.50
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "3.7.39"
},
{
"fixed": "3.7.51"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"3.7.39",
"3.7.40",
"3.7.40.1",
"3.7.41",
"3.7.42",
"3.7.43",
"3.7.44",
"3.7.45",
"3.7.45.1",
"3.7.45.2",
"3.7.46",
"3.7.47",
"3.7.47.1",
"3.7.48",
"3.7.49",
"3.7.50"
]
}