Apache Tomcat - HTTP/2 no-authority bypass of strict SNI validation
The advisory, in context
Improper Input Validation vulnerability in Apache Tomcat due to incomplete fix for CVE-2026-32990.
This issue affects Apache Tomcat: from 11.0.20 through 11.0.24, from 10.1.53 through 10.1.57, from 9.0.115 through 9.0.120.
Users are recommended to upgrade to version 11.0.25, 10.1.59 or 9.0.121, which fix the issue.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
From 11.0.20 before 11.0.25
Fixed in 11.0.25
5 explicitly affected versions
11.0.20, 11.0.21, 11.0.22, 11.0.23, 11.0.24
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "11.0.20"
},
{
"fixed": "11.0.25"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"11.0.20",
"11.0.21",
"11.0.22",
"11.0.23",
"11.0.24"
]
}From 10.1.53 before 10.1.59
Fixed in 10.1.59
5 explicitly affected versions
10.1.53, 10.1.54, 10.1.55, 10.1.56, 10.1.57
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "10.1.53"
},
{
"fixed": "10.1.59"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"10.1.53",
"10.1.54",
"10.1.55",
"10.1.56",
"10.1.57"
]
}From 9.0.115 before 9.0.121
Fixed in 9.0.121
6 explicitly affected versions
9.0.115, 9.0.116, 9.0.117, 9.0.118, 9.0.119, 9.0.120
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "9.0.115"
},
{
"fixed": "9.0.121"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"9.0.115",
"9.0.116",
"9.0.117",
"9.0.118",
"9.0.119",
"9.0.120"
]
}From 11.0.20 before 11.0.25
Fixed in 11.0.25
5 explicitly affected versions
11.0.20, 11.0.21, 11.0.22, 11.0.23, 11.0.24
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "11.0.20"
},
{
"fixed": "11.0.25"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"11.0.20",
"11.0.21",
"11.0.22",
"11.0.23",
"11.0.24"
]
}From 10.1.53 before 10.1.59
Fixed in 10.1.59
5 explicitly affected versions
10.1.53, 10.1.54, 10.1.55, 10.1.56, 10.1.57
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "10.1.53"
},
{
"fixed": "10.1.59"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"10.1.53",
"10.1.54",
"10.1.55",
"10.1.56",
"10.1.57"
]
}From 9.0.115 before 9.0.121
Fixed in 9.0.121
6 explicitly affected versions
9.0.115, 9.0.116, 9.0.117, 9.0.118, 9.0.119, 9.0.120
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "9.0.115"
},
{
"fixed": "9.0.121"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"9.0.115",
"9.0.116",
"9.0.117",
"9.0.118",
"9.0.119",
"9.0.120"
]
}References
- https://nvd.nist.gov/vuln/detail/CVE-2026-65637
- https://github.com/apache/tomcat/commit/40012414df828a56126f76a7339669c7c919aae7
- https://github.com/apache/tomcat/commit/8639b20f045c88f356b887204f52e897399f0de7
- https://github.com/apache/tomcat/commit/b823e88da077f5fa973e34d72359bded9f621e3c
- https://github.com/apache/tomcat
- https://github.com/apache/tomcat/releases/tag/10.1.58
- https://github.com/apache/tomcat/releases/tag/11.0.25
- https://github.com/apache/tomcat/releases/tag/9.0.121
- https://lists.apache.org/thread/djog953z1ohsyt25bdvhfzbmsy22vgcj
- https://tomcat.apache.org/security-10.html
- https://tomcat.apache.org/security-11.html
- https://tomcat.apache.org/security-9.html