ke_search (aka Faceted Search) vulnerable to Cross-Site Scripting
The advisory, in context
The ke_search (aka Faceted Search) extension before 4.0.3, 4.1.x through 4.6.x before 4.6.6, and 5.x before 5.0.2 for TYPO3 allows XSS via indexed data.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
From 5.0.0 before 5.0.2
Fixed in 5.0.2
2 explicitly affected versions
v5.0.0, v5.0.1
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "5.0.0"
},
{
"fixed": "5.0.2"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v5.0.0",
"v5.0.1"
]
}From 4.1.0 before 4.6.6
Fixed in 4.6.6
18 explicitly affected versions
v4.1.0, v4.2.0, v4.3.0, v4.3.1, v4.4.0, v4.4.1, v4.4.2, v4.4.3, v4.4.4, v4.4.5, v4.5.0, v4.5.1, v4.6.0, v4.6.1, v4.6.2, v4.6.3, v4.6.4, v4.6.5
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "4.1.0"
},
{
"fixed": "4.6.6"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v4.1.0",
"v4.2.0",
"v4.3.0",
"v4.3.1",
"v4.4.0",
"v4.4.1",
"v4.4.2",
"v4.4.3",
"v4.4.4",
"v4.4.5",
"v4.5.0",
"v4.5.1",
"v4.6.0",
"v4.6.1",
"v4.6.2",
"v4.6.3",
"v4.6.4",
"v4.6.5"
]
}Earlier releases before 4.0.3
Fixed in 4.0.3
61 explicitly affected versions
1.99.0, 1.99.2, 1.99.4, 1.99.5, 1.99.7, 2.0.0, 2.0.1, 2.0.2, 2.0.3, 2.0.4, 2.1.0, 2.2.0, 2.2.1, 4.0.2, v2.3.0, v2.3.1, v2.4.0, v2.4.1, v2.4.2, v2.5.0, v2.6.0, v2.6.1, v2.6.2, v2.6.3, v2.7.0, v2.8.0, v2.8.1, v2.8.2, v2.8.3, v2.8.4, v3.0.0, v3.0.1, v3.0.2, v3.0.3, v3.0.4, v3.0.5, v3.0.6, v3.1.0, v3.1.1, v3.1.2, v3.1.3, v3.1.4, v3.1.5, v3.1.6, v3.2.0, v3.3.0, v3.3.1, v3.4.0, v3.4.1, v3.4.2, v3.5.0, v3.6.0, v3.6.1, v3.7.0, v3.7.1, v3.7.2, v3.8.0, v3.8.1, v3.9.0, v4.0.0, v4.0.1
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "4.0.3"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"1.99.0",
"1.99.2",
"1.99.4",
"1.99.5",
"1.99.7",
"2.0.0",
"2.0.1",
"2.0.2",
"2.0.3",
"2.0.4",
"2.1.0",
"2.2.0",
"2.2.1",
"4.0.2",
"v2.3.0",
"v2.3.1",
"v2.4.0",
"v2.4.1",
"v2.4.2",
"v2.5.0",
"v2.6.0",
"v2.6.1",
"v2.6.2",
"v2.6.3",
"v2.7.0",
"v2.8.0",
"v2.8.1",
"v2.8.2",
"v2.8.3",
"v2.8.4",
"v3.0.0",
"v3.0.1",
"v3.0.2",
"v3.0.3",
"v3.0.4",
"v3.0.5",
"v3.0.6",
"v3.1.0",
"v3.1.1",
"v3.1.2",
"v3.1.3",
"v3.1.4",
"v3.1.5",
"v3.1.6",
"v3.2.0",
"v3.3.0",
"v3.3.1",
"v3.4.0",
"v3.4.1",
"v3.4.2",
"v3.5.0",
"v3.6.0",
"v3.6.1",
"v3.7.0",
"v3.7.1",
"v3.7.2",
"v3.8.0",
"v3.8.1",
"v3.9.0",
"v4.0.0",
"v4.0.1"
]
}References
- https://nvd.nist.gov/vuln/detail/CVE-2023-35783
- https://github.com/tpwd/ke_search/commit/14fa0703c2469e04eb398be4ae6268ec6ad6e720
- https://github.com/tpwd/ke_search/commit/b0f05d7e7e207bc0d5051bd96f3ff43c5c3658c6
- https://github.com/tpwd/ke_search/commit/d81a1f2f3dcb612220d505b495bc2851b87f6f74
- https://github.com/FriendsOfPHP/security-advisories/blob/master/tpwd/ke_search/CVE-2023-35783.yaml
- https://github.com/tpwd/ke_search
- https://typo3.org/security/advisory/typo3-ext-sa-2023-004