GHSA-f3xw-vgc7-f7h8critical9.1
PEAR::Archive_Tar Directory Traversal vulnerability
The advisory, in context
Directory traversal vulnerability in PEAR::Archive_Tar 1.2, and other versions before 1.3.2, allows remote attackers to create and overwrite arbitrary files via certain crafted pathnames in a TAR archive.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
pear/archive_tar Packagist
Ecosystem versions
From 1.2 before 1.3.2
Fixed in 1.3.2
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "1.2"
},
{
"fixed": "1.3.2"
}
],
"type": "ECOSYSTEM"
}
],
"versions": []
}