XSS in Dolibarr
The advisory, in context
Dolibarr before 11.0.4 allows XSS.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
Earlier releases before 11.0.4
Fixed in 11.0.4
88 explicitly affected versions
10.0.0, 10.0.1, 10.0.2, 10.0.3, 10.0.4, 10.0.5, 10.0.6, 10.0.7, 11.0.0, 11.0.1, 11.0.2, 11.0.3, 3.6.0, 3.6.0-beta, 3.6.1, 3.6.2, 3.6.3, 3.6.4, 3.6.5, 3.6.6, 3.7.0, 3.7.1, 3.7.2, 3.7.3, 3.7.4, 3.8.0, 3.8.0-beta, 3.8.1, 3.8.2, 3.8.3, 3.8.4, 3.9.0, 3.9.0-rc, 3.9.0-rc2, 3.9.1, 3.9.2, 3.9.3, 3.9.4, 4.0.0, 4.0.0-beta, 4.0.0-rc, 4.0.0-rc2, 4.0.1, 4.0.2, 4.0.3, 4.0.4, 4.0.5, 4.0.6, 5.0.0, 5.0.0-beta, 5.0.0-rc1, 5.0.0-rc2, 5.0.1, 5.0.2, 5.0.3, 5.0.4, 5.0.5, 5.0.6, 5.0.7, 6.0.0, 6.0.0-beta, 6.0.0-rc, 6.0.1, 6.0.2, 6.0.3, 6.0.4, 6.0.5, 6.0.6, 6.0.7, 6.0.8, 7.0.0, 7.0.1, 7.0.2, 7.0.3, 7.0.4, 7.0.5, 8.0.0, 8.0.1, 8.0.2, 8.0.3, 8.0.4, 8.0.5, 8.0.6, 9.0.0, 9.0.1, 9.0.2, 9.0.3, 9.0.4
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "11.0.4"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"10.0.0",
"10.0.1",
"10.0.2",
"10.0.3",
"10.0.4",
"10.0.5",
"10.0.6",
"10.0.7",
"11.0.0",
"11.0.1",
"11.0.2",
"11.0.3",
"3.6.0",
"3.6.0-beta",
"3.6.1",
"3.6.2",
"3.6.3",
"3.6.4",
"3.6.5",
"3.6.6",
"3.7.0",
"3.7.1",
"3.7.2",
"3.7.3",
"3.7.4",
"3.8.0",
"3.8.0-beta",
"3.8.1",
"3.8.2",
"3.8.3",
"3.8.4",
"3.9.0",
"3.9.0-rc",
"3.9.0-rc2",
"3.9.1",
"3.9.2",
"3.9.3",
"3.9.4",
"4.0.0",
"4.0.0-beta",
"4.0.0-rc",
"4.0.0-rc2",
"4.0.1",
"4.0.2",
"4.0.3",
"4.0.4",
"4.0.5",
"4.0.6",
"5.0.0",
"5.0.0-beta",
"5.0.0-rc1",
"5.0.0-rc2",
"5.0.1",
"5.0.2",
"5.0.3",
"5.0.4",
"5.0.5",
"5.0.6",
"5.0.7",
"6.0.0",
"6.0.0-beta",
"6.0.0-rc",
"6.0.1",
"6.0.2",
"6.0.3",
"6.0.4",
"6.0.5",
"6.0.6",
"6.0.7",
"6.0.8",
"7.0.0",
"7.0.1",
"7.0.2",
"7.0.3",
"7.0.4",
"7.0.5",
"8.0.0",
"8.0.1",
"8.0.2",
"8.0.3",
"8.0.4",
"8.0.5",
"8.0.6",
"9.0.0",
"9.0.1",
"9.0.2",
"9.0.3",
"9.0.4"
]
}References
- https://nvd.nist.gov/vuln/detail/CVE-2020-13094
- https://github.com/Dolibarr/dolibarr
- https://github.com/Dolibarr/dolibarr/blob/11.0.4/ChangeLog
- https://www.dolibarr.org/dolibarr-erp-crm-11-0-4-maintenance-release-for-branch-11-0-is-available.php
- http://packetstormsecurity.com/files/157752/Dolibarr-11.0.3-Cross-Site-Scripting.html