GHSA-cwhp-rqfr-8462medium5.4
Moodle XSS Vulnerability
The advisory, in context
In Moodle 3.8, messages required extra sanitizing before updating the conversation overview, to prevent the risk of stored cross-site scripting.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
moodle/moodle Packagist
Ecosystem versions
From 3.8 before 3.8.1
Fixed in 3.8.1
4 explicitly affected versions
3.8, v3.8.0, v3.8.0-beta, v3.8.0-rc1
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "3.8"
},
{
"fixed": "3.8.1"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"3.8",
"v3.8.0",
"v3.8.0-beta",
"v3.8.0-rc1"
]
}