GHSA-cvhh-q5g5-qprpcritical9.8
Keras framework vulnerable to deserialization of untrusted data
The advisory, in context
Deserialization of untrusted data can occur in versions of the Keras framework running versions 3.11.0 up to but not including 3.11.3, enabling a maliciously uploaded Keras file containing a TorchModuleWrapper class to run arbitrary code on an end user’s system when loaded despite safe mode being enabled. The vulnerability can be triggered through both local and remote files.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
keras PyPI
Ecosystem versions
From 3.11.0 before 3.11.3
Fixed in 3.11.3
3 explicitly affected versions
3.11.0, 3.11.1, 3.11.2
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "3.11.0"
},
{
"fixed": "3.11.3"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"3.11.0",
"3.11.1",
"3.11.2"
]
}References
- https://nvd.nist.gov/vuln/detail/CVE-2025-49655
- https://github.com/keras-team/keras/pull/21575
- https://github.com/keras-team/keras
- https://github.com/pypa/advisory-database/tree/main/vulns/keras/PYSEC-2026-368.yaml
- https://hiddenlayer.com/sai_security_advisor/2025-10-keras
- https://pypi.org/project/keras