Injection in UserFrosting
The advisory, in context
In Userfrosting, versions v0.3.1 to v4.6.2 are vulnerable to Host Header Injection. By luring a victim application user to click on a link, an unauthenticated attacker can use the “forgot password” functionality to reset the victim’s password and successfully take over their account.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
From 0.3.1 before 4.6.3
Fixed in 4.6.3
49 explicitly affected versions
4.1.0-Alpha, 4.1.1-alpha, 4.1.2-alpha, v4.1.10-alpha, v4.1.11-alpha, v4.1.12-alpha, v4.1.13-alpha, v4.1.14-alpha, v4.1.15-alpha, v4.1.16, v4.1.17, v4.1.18, v4.1.19, v4.1.20, v4.1.21, v4.1.22, v4.1.3-alpha, v4.1.4-alpha, v4.1.5-alpha, v4.1.6-alpha, v4.1.7-alpha, v4.1.8-alpha, v4.1.9-alpha, v4.2.0, v4.2.0-alpha.1, v4.2.0-alpha.2, v4.2.0-beta.1, v4.2.0-beta.2, v4.2.2, v4.2.3, v4.2.4, v4.3.0, v4.3.0-beta.1, v4.3.1, v4.3.2, v4.3.3, v4.3.4, v4.4.0, v4.4.1, v4.4.2, v4.4.3, v4.4.4, v4.4.5, v4.5.0, v4.5.1, v4.5.2, v4.6.0, v4.6.1, v4.6.2
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0.3.1"
},
{
"fixed": "4.6.3"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"4.1.0-Alpha",
"4.1.1-alpha",
"4.1.2-alpha",
"v4.1.10-alpha",
"v4.1.11-alpha",
"v4.1.12-alpha",
"v4.1.13-alpha",
"v4.1.14-alpha",
"v4.1.15-alpha",
"v4.1.16",
"v4.1.17",
"v4.1.18",
"v4.1.19",
"v4.1.20",
"v4.1.21",
"v4.1.22",
"v4.1.3-alpha",
"v4.1.4-alpha",
"v4.1.5-alpha",
"v4.1.6-alpha",
"v4.1.7-alpha",
"v4.1.8-alpha",
"v4.1.9-alpha",
"v4.2.0",
"v4.2.0-alpha.1",
"v4.2.0-alpha.2",
"v4.2.0-beta.1",
"v4.2.0-beta.2",
"v4.2.2",
"v4.2.3",
"v4.2.4",
"v4.3.0",
"v4.3.0-beta.1",
"v4.3.1",
"v4.3.2",
"v4.3.3",
"v4.3.4",
"v4.4.0",
"v4.4.1",
"v4.4.2",
"v4.4.3",
"v4.4.4",
"v4.4.5",
"v4.5.0",
"v4.5.1",
"v4.5.2",
"v4.6.0",
"v4.6.1",
"v4.6.2"
]
}