Moodle does not provide charset information in HTTP headers
The advisory, in context
lib/setup.php in Moodle through 2.4.11, 2.5.x before 2.5.9, 2.6.x before 2.6.6, and 2.7.x before 2.7.3 does not provide charset information in HTTP headers, which might allow remote attackers to conduct cross-site scripting (XSS) attacks via UTF-7 characters during interaction with AJAX scripts.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
Earlier releases before 2.5.9
Fixed in 2.5.9
32 explicitly affected versions
v2.3.10, v2.3.11, v2.3.4, v2.3.5, v2.3.6, v2.3.7, v2.3.8, v2.3.9, v2.4.0, v2.4.0-rc1, v2.4.1, v2.4.10, v2.4.11, v2.4.2, v2.4.3, v2.4.4, v2.4.5, v2.4.6, v2.4.7, v2.4.8, v2.4.9, v2.5.0, v2.5.0-beta, v2.5.0-rc1, v2.5.1, v2.5.2, v2.5.3, v2.5.4, v2.5.5, v2.5.6, v2.5.7, v2.5.8
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "2.5.9"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v2.3.10",
"v2.3.11",
"v2.3.4",
"v2.3.5",
"v2.3.6",
"v2.3.7",
"v2.3.8",
"v2.3.9",
"v2.4.0",
"v2.4.0-rc1",
"v2.4.1",
"v2.4.10",
"v2.4.11",
"v2.4.2",
"v2.4.3",
"v2.4.4",
"v2.4.5",
"v2.4.6",
"v2.4.7",
"v2.4.8",
"v2.4.9",
"v2.5.0",
"v2.5.0-beta",
"v2.5.0-rc1",
"v2.5.1",
"v2.5.2",
"v2.5.3",
"v2.5.4",
"v2.5.5",
"v2.5.6",
"v2.5.7",
"v2.5.8"
]
}From 2.6.0 before 2.6.6
Fixed in 2.6.6
6 explicitly affected versions
v2.6.0, v2.6.1, v2.6.2, v2.6.3, v2.6.4, v2.6.5
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "2.6.0"
},
{
"fixed": "2.6.6"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v2.6.0",
"v2.6.1",
"v2.6.2",
"v2.6.3",
"v2.6.4",
"v2.6.5"
]
}From 2.7.0 before 2.7.3
Fixed in 2.7.3
3 explicitly affected versions
v2.7.0, v2.7.1, v2.7.2
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "2.7.0"
},
{
"fixed": "2.7.3"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v2.7.0",
"v2.7.1",
"v2.7.2"
]
}References
- https://nvd.nist.gov/vuln/detail/CVE-2014-9059
- https://github.com/moodle/moodle/commit/0a0145c5e8041aadeff303a9f9984c86706b4e42
- https://github.com/moodle/moodle/commit/293e4bbcb71f0a801c2539ea051c58688314b23a
- https://github.com/moodle/moodle/commit/3c98b7a5ad1bb596a738e550fc3bf966d6415fe0
- https://github.com/moodle/moodle/commit/ac6e453d11024bf6ad99ada1bfc641c6b91ebed6
- https://github.com/moodle/moodle
- https://moodle.org/mod/forum/discuss.php?d=275146
- https://web.archive.org/web/20150914064838/http://www.securitytracker.com/id/1031215
- https://web.archive.org/web/20200229043651/http://www.securityfocus.com/bid/71133
- http://git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-47966
- http://www.securitytracker.com/id/1031215