GHSA-cpxc-67rc-c775high7.3
Cross Site Scripting in baserCMS
The advisory, in context
baserCMS 4.3.6 and earlier is affected by Cross Site Scripting (XSS).
- Impact: XSS via Arbitrary script execution.
- Attack vector is: Administrator must be logged in.
- Components are: content_fields.php, content_info.php, content_options.php, content_related.php, index_list_tree.php, jquery.bcTree.js
- Tested baserCMS Version : 4.3.6 (Latest)
- Affected baserCMS Version : 4.0.0 ~ 4.3.6
- Patches : https://basercms.net/security/20200827
Found by Aquilao Null
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
baserproject/basercms Packagist
Ecosystem versions
From 4.0.0 before 4.3.7
Fixed in 4.3.7
39 explicitly affected versions
4.0.0, 4.0.1, 4.0.10, 4.0.10.1, 4.0.11, 4.0.2, 4.0.2.1, 4.0.3, 4.0.4, 4.0.5, 4.0.5.1, 4.0.5.2, 4.0.6, 4.0.7, 4.0.8, 4.0.9, 4.1.0, 4.1.0.1, 4.1.1, 4.1.2, 4.1.3, 4.1.4, 4.1.5, 4.1.6, 4.1.7, 4.1.8, 4.2.0, 4.2.1, 4.2.2, 4.2.3, 4.2.4, 4.2.5, 4.3.0, 4.3.1, 4.3.2, 4.3.3, 4.3.4, 4.3.5, 4.3.6
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "4.0.0"
},
{
"fixed": "4.3.7"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"4.0.0",
"4.0.1",
"4.0.10",
"4.0.10.1",
"4.0.11",
"4.0.2",
"4.0.2.1",
"4.0.3",
"4.0.4",
"4.0.5",
"4.0.5.1",
"4.0.5.2",
"4.0.6",
"4.0.7",
"4.0.8",
"4.0.9",
"4.1.0",
"4.1.0.1",
"4.1.1",
"4.1.2",
"4.1.3",
"4.1.4",
"4.1.5",
"4.1.6",
"4.1.7",
"4.1.8",
"4.2.0",
"4.2.1",
"4.2.2",
"4.2.3",
"4.2.4",
"4.2.5",
"4.3.0",
"4.3.1",
"4.3.2",
"4.3.3",
"4.3.4",
"4.3.5",
"4.3.6"
]
}