Connect-CMS has DOM-based Cross-Site Scripting (XSS) in the Cabinet Plugin List View
The advisory, in context
Security Advisory — Cabinet Plugin (DOM-based XSS)
Summary
A DOM-based Cross-Site Scripting (XSS) issue exists in the Cabinet Plugin list view.
Affected Versions
- 1.x series: >= 1.35.0, <= 1.41.0
- 2.x series: >= 2.35.0, <= 2.41.0
Patched Versions
- 1.41.1
- 2.41.1
Description
In the Cabinet Plugin list view, DOM-based Cross-Site Scripting (XSS) could occur due to how saved names were rendered. If exploited, arbitrary script could run in the victim's browser, which may lead to unauthorized actions or information theft. Exploitation requires that the attacker be able to reach the affected functionality as an authenticated user. Users affected by this vulnerability should update to a fixed version.
Solution
Update to the fixed version. For the 1.x series, update to 1.41.1 or later. For the 2.x series, update to 2.41.1 or later.
Credits
OpenSource WorkShop thanks Sho Odagiri (小田切 祥) of GMO Cybersecurity by Ierae, Inc. for reporting this vulnerability.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
From 1.35.0 before 1.41.1
Fixed in 1.41.1
8 explicitly affected versions
v1.35.0, v1.36.0, v1.37.0, v1.38.0, v1.38.1, v1.39.0, v1.40.0, v1.41.0
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "1.35.0"
},
{
"fixed": "1.41.1"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v1.35.0",
"v1.36.0",
"v1.37.0",
"v1.38.0",
"v1.38.1",
"v1.39.0",
"v1.40.0",
"v1.41.0"
]
}From 2.35.0 before 2.41.1
Fixed in 2.41.1
8 explicitly affected versions
v2.35.0, v2.36.0, v2.37.0, v2.38.0, v2.38.1, v2.39.0, v2.40.0, v2.41.0
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "2.35.0"
},
{
"fixed": "2.41.1"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v2.35.0",
"v2.36.0",
"v2.37.0",
"v2.38.0",
"v2.38.1",
"v2.39.0",
"v2.40.0",
"v2.41.0"
]
}References
- https://github.com/opensource-workshop/connect-cms/security/advisories/GHSA-cmfh-mpmf-fmq4
- https://nvd.nist.gov/vuln/detail/CVE-2026-32277
- https://github.com/opensource-workshop/connect-cms/commit/c04dc40f814eff891915752ef1ec00ba6612441c
- https://github.com/opensource-workshop/connect-cms
- https://github.com/opensource-workshop/connect-cms/releases/tag/v1.41.1
- https://github.com/opensource-workshop/connect-cms/releases/tag/v2.41.1