Moodle allows attackers to extract archives to arbitrary directories
The advisory, in context
mdeploy.php in Moodle through 2.5.9, 2.6.x before 2.6.9, 2.7.x before 2.7.6, and 2.8.x before 2.8.4 allows remote authenticated users to bypass intended access restrictions and extract archives to arbitrary directories via a crafted dataroot value.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
Earlier releases before 2.6.9
Fixed in 2.6.9
44 explicitly affected versions
v2.3.10, v2.3.11, v2.3.4, v2.3.5, v2.3.6, v2.3.7, v2.3.8, v2.3.9, v2.4.0, v2.4.0-rc1, v2.4.1, v2.4.10, v2.4.11, v2.4.2, v2.4.3, v2.4.4, v2.4.5, v2.4.6, v2.4.7, v2.4.8, v2.4.9, v2.5.0, v2.5.0-beta, v2.5.0-rc1, v2.5.1, v2.5.2, v2.5.3, v2.5.4, v2.5.5, v2.5.6, v2.5.7, v2.5.8, v2.5.9, v2.6.0, v2.6.0-beta, v2.6.0-rc1, v2.6.1, v2.6.2, v2.6.3, v2.6.4, v2.6.5, v2.6.6, v2.6.7, v2.6.8
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "2.6.9"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v2.3.10",
"v2.3.11",
"v2.3.4",
"v2.3.5",
"v2.3.6",
"v2.3.7",
"v2.3.8",
"v2.3.9",
"v2.4.0",
"v2.4.0-rc1",
"v2.4.1",
"v2.4.10",
"v2.4.11",
"v2.4.2",
"v2.4.3",
"v2.4.4",
"v2.4.5",
"v2.4.6",
"v2.4.7",
"v2.4.8",
"v2.4.9",
"v2.5.0",
"v2.5.0-beta",
"v2.5.0-rc1",
"v2.5.1",
"v2.5.2",
"v2.5.3",
"v2.5.4",
"v2.5.5",
"v2.5.6",
"v2.5.7",
"v2.5.8",
"v2.5.9",
"v2.6.0",
"v2.6.0-beta",
"v2.6.0-rc1",
"v2.6.1",
"v2.6.2",
"v2.6.3",
"v2.6.4",
"v2.6.5",
"v2.6.6",
"v2.6.7",
"v2.6.8"
]
}From 2.7.0 before 2.7.6
Fixed in 2.7.6
6 explicitly affected versions
v2.7.0, v2.7.1, v2.7.2, v2.7.3, v2.7.4, v2.7.5
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "2.7.0"
},
{
"fixed": "2.7.6"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v2.7.0",
"v2.7.1",
"v2.7.2",
"v2.7.3",
"v2.7.4",
"v2.7.5"
]
}From 2.8.0 before 2.8.4
Fixed in 2.8.4
4 explicitly affected versions
v2.8.0, v2.8.1, v2.8.2, v2.8.3
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "2.8.0"
},
{
"fixed": "2.8.4"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v2.8.0",
"v2.8.1",
"v2.8.2",
"v2.8.3"
]
}References
- https://nvd.nist.gov/vuln/detail/CVE-2015-2267
- https://github.com/moodle/moodle/commit/12a8fcb5e45c58ee8267ad0472852c2b80a19878
- https://github.com/moodle/moodle/commit/240e7be7341afa31096fdbf3f242a7966f6237ab
- https://github.com/moodle/moodle/commit/4475f1e478370fb97933127ec60e40f39e285da1
- https://github.com/moodle/moodle/commit/76da7e9bc88669eab62f83f04639ba356a0b0c5a
- https://github.com/moodle/moodle/commit/83866c3c2a5b1391317172eea0b4f017c6d142d2
- https://github.com/moodle/moodle/commit/84f9f60b67e1e20058fbe2afa473607d075aff63
- https://github.com/moodle/moodle/commit/8d9bdd28e049ca6b6b2a4ab8f142097c2f907df6
- https://github.com/moodle/moodle/commit/a47aabc7833d0c88a83791d99a1204742c33f59b
- https://github.com/moodle/moodle/commit/c353a6202658f320096a41e94494063393153b7f
- https://github.com/moodle/moodle/commit/de169b7944e36d374d55e3f396d90ab2b4303afb
- https://github.com/moodle/moodle
- https://moodle.org/mod/forum/discuss.php?d=307381
- http://git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-49087
- http://openwall.com/lists/oss-security/2015/03/16/1