Cross-site Scripting in TastyIgniter
The advisory, in context
TastyIgniter prior to version 3.3.0 is vulnerable to Document Object Model (DOM) based Cross-site Scripting (XSS).
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
Earlier releases before 3.3.0
Fixed in 3.3.0
67 explicitly affected versions
2.1.0, 2.1.0-rc.1, 2.1.0-rc.2, 2.1.1, v0.5.0, v1.0.0, v1.1.0, v1.2.0, v1.2.1, v1.3.0, v1.3.1, v1.4.0, v1.4.1, v3.0.4, v3.0.4-beta, v3.0.4-beta.10, v3.0.4-beta.11, v3.0.4-beta.12, v3.0.4-beta.13, v3.0.4-beta.14, v3.0.4-beta.15, v3.0.4-beta.16, v3.0.4-beta.17, v3.0.4-beta.18, v3.0.4-beta.19, v3.0.4-beta.2, v3.0.4-beta.20, v3.0.4-beta.20.1, v3.0.4-beta.21, v3.0.4-beta.22, v3.0.4-beta.22.1, v3.0.4-beta.22.2, v3.0.4-beta.22.3, v3.0.4-beta.22.4, v3.0.4-beta.23, v3.0.4-beta.23.1, v3.0.4-beta.23.2, v3.0.4-beta.24, v3.0.4-beta.24.1, v3.0.4-beta.24.2, v3.0.4-beta.24.3, v3.0.4-beta.24.4, v3.0.4-beta.25, v3.0.4-beta.25.1, v3.0.4-beta.25.2, v3.0.4-beta.26, v3.0.4-beta.27, v3.0.4-beta.28, v3.0.4-beta.3, v3.0.4-beta.4, v3.0.4-beta.5, v3.0.4-beta.6, v3.0.4-beta.7, v3.0.4-beta.8, v3.0.4-beta.9, v3.0.4-beta.9.1, v3.0.5, v3.0.6, v3.0.7, v3.0.8, v3.1.0, v3.1.0-rc.1, v3.1.1, v3.1.2, v3.2.0, v3.2.1, v3.2.2
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "3.3.0"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"2.1.0",
"2.1.0-rc.1",
"2.1.0-rc.2",
"2.1.1",
"v0.5.0",
"v1.0.0",
"v1.1.0",
"v1.2.0",
"v1.2.1",
"v1.3.0",
"v1.3.1",
"v1.4.0",
"v1.4.1",
"v3.0.4",
"v3.0.4-beta",
"v3.0.4-beta.10",
"v3.0.4-beta.11",
"v3.0.4-beta.12",
"v3.0.4-beta.13",
"v3.0.4-beta.14",
"v3.0.4-beta.15",
"v3.0.4-beta.16",
"v3.0.4-beta.17",
"v3.0.4-beta.18",
"v3.0.4-beta.19",
"v3.0.4-beta.2",
"v3.0.4-beta.20",
"v3.0.4-beta.20.1",
"v3.0.4-beta.21",
"v3.0.4-beta.22",
"v3.0.4-beta.22.1",
"v3.0.4-beta.22.2",
"v3.0.4-beta.22.3",
"v3.0.4-beta.22.4",
"v3.0.4-beta.23",
"v3.0.4-beta.23.1",
"v3.0.4-beta.23.2",
"v3.0.4-beta.24",
"v3.0.4-beta.24.1",
"v3.0.4-beta.24.2",
"v3.0.4-beta.24.3",
"v3.0.4-beta.24.4",
"v3.0.4-beta.25",
"v3.0.4-beta.25.1",
"v3.0.4-beta.25.2",
"v3.0.4-beta.26",
"v3.0.4-beta.27",
"v3.0.4-beta.28",
"v3.0.4-beta.3",
"v3.0.4-beta.4",
"v3.0.4-beta.5",
"v3.0.4-beta.6",
"v3.0.4-beta.7",
"v3.0.4-beta.8",
"v3.0.4-beta.9",
"v3.0.4-beta.9.1",
"v3.0.5",
"v3.0.6",
"v3.0.7",
"v3.0.8",
"v3.1.0",
"v3.1.0-rc.1",
"v3.1.1",
"v3.1.2",
"v3.2.0",
"v3.2.1",
"v3.2.2"
]
}