GIVE YOUR AGENT THE EVIDENCE

Set up in your agent.

One prompt to get started. Paste it into your coding agent to connect cve.new through MCP and bring vulnerability context into your workflow.

Your agent needs remote MCP support and access to https://cve.new/mcp.

Read the setup guide

GIVE YOUR AGENT THE EVIDENCE

Investigate in your agent.

Turn this advisory into a focused investigation. Ask your agent to check your project’s versions, explain the evidence, and suggest a compatible fix.

Your agent needs remote MCP support and access to https://cve.new/mcp.

Read the setup guide

GHSA-cj3w-g42v-wcj6high7.1

ibexa/fieldtype-richtext allows access to external entities in XML

No CVE assignedCheck your stack

The advisory, in context

Impact

This security advisory resolves a vulnerability in the RichText field type. By entering a maliciously crafted input into the RichText XML, an attacker could perform an attack using XML external entity (XXE) injection, which might be able to read files on the server. To exploit this vulnerability the attacker would need to already have edit permission to content with RichText fields, which typically means Editor role or higher. The fix removes unsafe elements from XML code, while preserving safe elements.

If you have a stored XXE attack in your content drafts, the fix prevents it from extracting data both during editing and preview. However, if such an attack has already been published and the result is stored in the content, it is unfortunately not possible to detect and remove it by automatic means.

Credits

This vulnerability was discovered and reported to Ibexa by Dennis Henke, Thorsten Niephaus, Marat Aytuganov, and Stephan Sekula of Compass Security Deutschland GmbH. We thank them for reporting it responsibly to us.

Patches

Workarounds

  • Exploitation requires edit access to RichText content. If you can trust your editors, and you don't grant edit permission to any externals, you are not at risk in practice.

References

Affected packages

Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.

Ecosystem versions

From 4.6.0-beta1 before 4.6.19

Fixed in 4.6.19

25 explicitly affected versions

v4.6.0, v4.6.0-beta1, v4.6.0-beta2, v4.6.0-beta3, v4.6.0-beta4, v4.6.0-beta5, v4.6.0-rc1, v4.6.1, v4.6.10, v4.6.11, v4.6.12, v4.6.13, v4.6.14, v4.6.15, v4.6.16, v4.6.17, v4.6.18, v4.6.2, v4.6.3, v4.6.4, v4.6.5, v4.6.6, v4.6.7, v4.6.8, v4.6.9

View affected-version evidence
{
  "ranges": [
    {
      "events": [
        {
          "introduced": "4.6.0-beta1"
        },
        {
          "fixed": "4.6.19"
        }
      ],
      "type": "ECOSYSTEM"
    }
  ],
  "versions": [
    "v4.6.0",
    "v4.6.0-beta1",
    "v4.6.0-beta2",
    "v4.6.0-beta3",
    "v4.6.0-beta4",
    "v4.6.0-beta5",
    "v4.6.0-rc1",
    "v4.6.1",
    "v4.6.10",
    "v4.6.11",
    "v4.6.12",
    "v4.6.13",
    "v4.6.14",
    "v4.6.15",
    "v4.6.16",
    "v4.6.17",
    "v4.6.18",
    "v4.6.2",
    "v4.6.3",
    "v4.6.4",
    "v4.6.5",
    "v4.6.6",
    "v4.6.7",
    "v4.6.8",
    "v4.6.9"
  ]
}

References