GHSA-cgrv-6h2h-6f7vhigh7.0
MODX Revolution Directory Traversal Vulnerability
The advisory, in context
In MODX Revolution before 2.5.7, when PHP 5.3.3 is used, an attacker is able to include and execute arbitrary files on the web server due to insufficient validation of the action parameter to setup/index.php, aka directory traversal.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
modx/revolution Packagist
Ecosystem versions
Earlier releases before 2.5.7
Fixed in 2.5.7
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "2.5.7"
}
],
"type": "ECOSYSTEM"
}
],
"versions": []
}