GHSA-cg4m-qjjp-7497medium
TYPO3 Cross-Site Scripting in link validator component
No CVE assignedCheck your stack
The advisory, in context
Failing to sanitize content from editors, the link validator component is susceptible to Cross-Site Scripting. A valid editor account with access to content which is scanned by the link validator component is required to exploit this vulnerability.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
typo3/cms Packagist
Ecosystem versions
From 6.2.0 before 6.2.18
Fixed in 6.2.18
19 explicitly affected versions
6.2.0, 6.2.1, 6.2.10, 6.2.10-rc1, 6.2.11, 6.2.12, 6.2.13, 6.2.14, 6.2.15, 6.2.16, 6.2.17, 6.2.2, 6.2.3, 6.2.4, 6.2.5, 6.2.6, 6.2.7, 6.2.8, 6.2.9
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "6.2.0"
},
{
"fixed": "6.2.18"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"6.2.0",
"6.2.1",
"6.2.10",
"6.2.10-rc1",
"6.2.11",
"6.2.12",
"6.2.13",
"6.2.14",
"6.2.15",
"6.2.16",
"6.2.17",
"6.2.2",
"6.2.3",
"6.2.4",
"6.2.5",
"6.2.6",
"6.2.7",
"6.2.8",
"6.2.9"
]
}typo3/cms Packagist
Ecosystem versions
From 7.6.0 before 7.6.3
Fixed in 7.6.3
3 explicitly affected versions
7.6.0, 7.6.1, 7.6.2
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "7.6.0"
},
{
"fixed": "7.6.3"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"7.6.0",
"7.6.1",
"7.6.2"
]
}