Privilage Escalation in moodle
Impact
If the upload course tool in Moodle was used to delete an enrollment method which did not exist or was not already enabled, the tool would erroneously enable that enrollment method. This could lead to unintended users gaining access to the course. Versions affected: 3.9 to 3.9.2, 3.8 to 3.8.5, 3.7 to 3.7.8, 3.5 to 3.5.14 and earlier unsupported versions. This is fixed in moodle 3.9.3, 3.8.6, 3.7.9, 3.5.15, and 3.10.
Source excerpt · OSVAffected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
| Affected range | Recorded fix |
|---|---|
| From 3.9.0 before 3.9.3Ecosystem versions | 3.9.3 |
| From 3.8.0 before 3.8.6Ecosystem versions | 3.8.6 |
| From 3.7.0 before 3.7.9Ecosystem versions | 3.7.9 |
| From 3.5 before 3.5.15Ecosystem versions | 3.5.15 |
Version evidence: OSV · GHSA-c9hq-g4q8-w893
View original version evidence (35 explicit versions)
Original source description
If the upload course tool in Moodle was used to delete an enrollment method which did not exist or was not already enabled, the tool would erroneously enable that enrollment method. This could lead to unintended users gaining access to the course. Versions affected: 3.9 to 3.9.2, 3.8 to 3.8.5, 3.7 to 3.7.8, 3.5 to 3.5.14 and earlier unsupported versions. This is fixed in moodle 3.9.3, 3.8.6, 3.7.9, 3.5.15, and 3.10.
References
- Security advisory nvd.nist.gov/vuln/detail/CVE-2020-25701
- Patch github.com/moodle/moodle/commit/b8e1eec4c77c858de87fedf4e405e929539ea0c5
- Source reference bugzilla.redhat.com/show_bug.cgi
- Source reference lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/4NNFCHPPHRJNJROIX6SYMHOC6HMKP3GU
- Source reference lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/B55KXBVAT45MDASJ3EK6VIGQOYGJ4NH6
- Source reference moodle.org/mod/forum/discuss.php