GHSA-c962-g533-823fmedium4.8
Cross-site Scripting in Bagisto
The advisory, in context
Cross Site Scripting vulnerability in webkil Bagisto v1.3.1 and before allows an attacker to execute arbitrary code via a crafted SVG file uplad.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
bagisto/bagisto Packagist
Ecosystem versions
Earlier releases before 1.3.2
Fixed in 1.3.2
30 explicitly affected versions
v0.1.0, v0.1.1, v0.1.2, v0.1.3, v0.1.4, v0.1.4-BETA1, v0.1.4-BETA2, v0.1.4-BETA3, v0.1.4-BETA4, v0.1.5, v0.1.6, v0.1.6-ALPHA1, v0.1.7, v0.1.7-BETA1, v0.1.7-BETA2, v0.1.8, v0.1.9, v0.1.9-BETA1, v0.2.0, v0.2.1, v0.2.2, v1.0.0, v1.0.0-BETA1, v1.1.0, v1.1.1, v1.1.2, v1.2.0, v1.2.0-BETA1, v1.3.0, v1.3.1
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "1.3.2"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v0.1.0",
"v0.1.1",
"v0.1.2",
"v0.1.3",
"v0.1.4",
"v0.1.4-BETA1",
"v0.1.4-BETA2",
"v0.1.4-BETA3",
"v0.1.4-BETA4",
"v0.1.5",
"v0.1.6",
"v0.1.6-ALPHA1",
"v0.1.7",
"v0.1.7-BETA1",
"v0.1.7-BETA2",
"v0.1.8",
"v0.1.9",
"v0.1.9-BETA1",
"v0.2.0",
"v0.2.1",
"v0.2.2",
"v1.0.0",
"v1.0.0-BETA1",
"v1.1.0",
"v1.1.1",
"v1.1.2",
"v1.2.0",
"v1.2.0-BETA1",
"v1.3.0",
"v1.3.1"
]
}References
- https://nvd.nist.gov/vuln/detail/CVE-2023-36236
- https://github.com/bagisto/bagisto/pull/4764/commits/7bbf0c4bb565fc2601f031f9bbcdfa06e24dbd45
- https://github.com/bagisto/bagisto/commit/7bbf0c4bb565fc2601f031f9bbcdfa06e24dbd45
- https://bagisto.com/en
- https://github.com/Ek-Saini/security/blob/main/XSS_via_fileupload-bagisto