GHSA-c73w-4rcj-2622medium
Typo3 API Install Tool vulnerable to Cross-site Scripting
The advisory, in context
Cross-site scripting (XSS) vulnerability in the Install Tool subcomponent in TYPO3 4.0.13 and earlier, 4.1.x before 4.1.13, 4.2.x before 4.2.10, and 4.3.x before 4.3beta2 allows remote attackers to inject arbitrary web script or HTML via unspecified parameters.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
typo3/cms-install Packagist
Ecosystem versions
Earlier releases through 4.0.13 (inclusive)
No fix recorded for this interval.
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"last_affected": "4.0.13"
}
],
"type": "ECOSYSTEM"
}
],
"versions": []
}typo3/cms-install Packagist
Ecosystem versions
From 4.1.0 before 4.1.13
Fixed in 4.1.13
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "4.1.0"
},
{
"fixed": "4.1.13"
}
],
"type": "ECOSYSTEM"
}
],
"versions": []
}typo3/cms-install Packagist
Ecosystem versions
From 4.2.0 before 4.2.10
Fixed in 4.2.10
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "4.2.0"
},
{
"fixed": "4.2.10"
}
],
"type": "ECOSYSTEM"
}
],
"versions": []
}typo3/cms-install Packagist
Ecosystem versions
From 4.3alpha1 before 4.3beta2
Fixed in 4.3beta2
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "4.3alpha1"
},
{
"fixed": "4.3beta2"
}
],
"type": "ECOSYSTEM"
}
],
"versions": []
}References
- https://nvd.nist.gov/vuln/detail/CVE-2009-3636
- https://exchange.xforce.ibmcloud.com/vulnerabilities/53929
- https://github.com/TYPO3-CMS/install
- https://web.archive.org/web/20101223093042/http://www.securityfocus.com/bid/36801
- http://marc.info/?l=oss-security&m=125632856206736&w=2
- http://marc.info/?l=oss-security&m=125633199111438&w=2
- http://typo3.org/teams/security/security-bulletins/typo3-sa-2009-016