GIVE YOUR AGENT THE EVIDENCE

Set up in your agent.

One prompt to get started. Paste it into your coding agent to connect cve.new through MCP and bring vulnerability context into your workflow.

Your agent needs remote MCP support and access to https://cve.new/mcp.

Read the setup guide

GIVE YOUR AGENT THE EVIDENCE

Investigate in your agent.

Turn this advisory into a focused investigation. Ask your agent to check your project’s versions, explain the evidence, and suggest a compatible fix.

Your agent needs remote MCP support and access to https://cve.new/mcp.

Read the setup guide

Check your stack
GHSA-c5wx-6c2c-f7rmhigh7.5

TYPO3 CMS vulnerable to Arbitrary Code Execution via Form Framework

Impact

Due to the lack of separating user-submitted data from the internal configuration in the Form Designer backend module, it was possible to inject code instructions to be processed and executed via TypoScript as PHP code.

Source excerpt · OSV

Affected packages

Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.

Affected rangeRecorded fix
From 8.0.0 before 8.7.49Ecosystem versions8.7.49
From 9.0.0 before 9.5.38Ecosystem versions9.5.38
From 10.0.0 before 10.4.33Ecosystem versions10.4.33
From 11.0.0 before 11.5.20Ecosystem versions11.5.20
From 12.0.0 before 12.1.1Ecosystem versions12.1.1

Version evidence: OSV · GHSA-c5wx-6c2c-f7rm

View original version evidence (137 explicit versions)
typo3/cms Packagist
Affected rangeRecorded fix
From 10.0.0 before 10.4.33Ecosystem versions10.4.33
From 11.0.0 before 11.5.20Ecosystem versions11.5.20
From 12.0.0 before 12.1.1Ecosystem versions12.1.1

Version evidence: OSV · GHSA-c5wx-6c2c-f7rm

View original version evidence (70 explicit versions)

Original source description

Problem

Due to the lack of separating user-submitted data from the internal configuration in the Form Designer backend module, it was possible to inject code instructions to be processed and executed via TypoScript as PHP code.

The existence of individual TypoScript instructions for a particular form item (known as formDefinitionOverrides) and a valid backend user account with access to the form module are needed to exploit this vulnerability.

Solution

Update to TYPO3 versions 8.7.49 ELTS, 9.5.38 ELTS, 10.4.33, 11.5.20, 12.1.1 that fix the problem described above.

References

References