YUI Cross-site Scripting (XSS) vulnerability
The advisory, in context
Cross-site scripting (XSS) vulnerability in flashuploader.swf in the Uploader component in Yahoo! YUI 3.5.0 through 3.9.1, as used in Moodle through 2.1.10, 2.2.x before 2.2.11, 2.3.x before 2.3.8, 2.4.x before 2.4.5, 2.5.x before 2.5.1, and other products, allows remote attackers to inject arbitrary web script or HTML via a crafted string in a URL.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
From 3.2.0 through 3.9.1 (inclusive)
No fix recorded for this interval.
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "3.2.0"
},
{
"last_affected": "3.9.1"
}
],
"type": "SEMVER"
}
],
"versions": []
}Earlier releases before 2.2.11
Fixed in 2.2.11
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "2.2.11"
}
],
"type": "ECOSYSTEM"
}
],
"versions": []
}From 2.3.0 before 2.3.8
Fixed in 2.3.8
4 explicitly affected versions
v2.3.4, v2.3.5, v2.3.6, v2.3.7
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "2.3.0"
},
{
"fixed": "2.3.8"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v2.3.4",
"v2.3.5",
"v2.3.6",
"v2.3.7"
]
}From 2.4.0-rc1 before 2.4.5
Fixed in 2.4.5
6 explicitly affected versions
v2.4.0, v2.4.0-rc1, v2.4.1, v2.4.2, v2.4.3, v2.4.4
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "2.4.0-rc1"
},
{
"fixed": "2.4.5"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v2.4.0",
"v2.4.0-rc1",
"v2.4.1",
"v2.4.2",
"v2.4.3",
"v2.4.4"
]
}From 2.5.0-beta before 2.5.1
Fixed in 2.5.1
3 explicitly affected versions
v2.5.0, v2.5.0-beta, v2.5.0-rc1
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "2.5.0-beta"
},
{
"fixed": "2.5.1"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v2.5.0",
"v2.5.0-beta",
"v2.5.0-rc1"
]
}