GHSA-9v3w-m552-m6ffmedium6.1
Pi Cross-site Scripting vulnerability
The advisory, in context
A Cross-Site Scripting (XSS) was discovered in pi-engine/pi 2.5.0. The vulnerability exists due to insufficient filtration of user-supplied data (preview) passed to the pi-develop/www/script/editor/markitup/preview/markdown.php URL. An attacker could execute arbitrary HTML and script code in a browser in the context of the vulnerable website.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
pi/pi Packagist
Ecosystem versions
Earlier releases before 2.6.0-alpha1
Fixed in 2.6.0-alpha1
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "2.6.0-alpha1"
}
],
"type": "ECOSYSTEM"
}
],
"versions": []
}