GIVE YOUR AGENT THE EVIDENCE

Set up in your agent.

One prompt to get started. Paste it into your coding agent to connect cve.new through MCP and bring vulnerability context into your workflow.

Your agent needs remote MCP support and access to https://cve.new/mcp.

Read the setup guide

GIVE YOUR AGENT THE EVIDENCE

Investigate in your agent.

Turn this advisory into a focused investigation. Ask your agent to check your project’s versions, explain the evidence, and suggest a compatible fix.

Your agent needs remote MCP support and access to https://cve.new/mcp.

Read the setup guide

Check your stack
GHSA-9v3m-8fp8-mj99medium6.1

Bootstrap Vulnerable to Cross-Site Scripting

Impact

Versions of bootstrap prior to 3.4.1 for 3.x and 4.3.1 for 4.x are vulnerable to Cross-Site Scripting (XSS). The data-template attribute of the tooltip and popover plugins lacks input sanitization and may allow attacker to execute arbitrary JavaScript.

Source excerpt · OSV

Affected packages

Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.

bootstrap RubyGems
Affected rangeRecorded fix
Earlier releases before 4.3.1Ecosystem versions4.3.1

Version evidence: OSV · GHSA-9v3m-8fp8-mj99

View original version evidence (18 explicit versions)
Affected rangeRecorded fix
From 3.0.0 before 3.4.1Ecosystem versions3.4.1

Version evidence: OSV · GHSA-9v3m-8fp8-mj99

View original version evidence (24 explicit versions)
Affected rangeRecorded fix
From 3.0.0 before 3.4.1Ecosystem versions3.4.1

Version evidence: OSV · GHSA-9v3m-8fp8-mj99

View original version evidence (6 explicit versions)
Affected rangeRecorded fix
From 4.0.0 before 4.3.1Ecosystem versions4.3.1
From 3.0.0 before 3.4.1Ecosystem versions3.4.1

Version evidence: OSV · GHSA-9v3m-8fp8-mj99

View original version evidence (24 explicit versions)
Affected rangeRecorded fix
Earlier releases before 4.3.1Ecosystem versions4.3.1

Version evidence: OSV · GHSA-9v3m-8fp8-mj99

View original version evidence (17 explicit versions)
Affected rangeRecorded fix
From 4.0.0 before 4.3.1Semantic versions4.3.1
From 3.0.0 before 3.4.1Semantic versions3.4.1

Version evidence: OSV · GHSA-9v3m-8fp8-mj99

View original version evidence (0 explicit versions)
Affected rangeRecorded fix
From 3.0.0 before 3.4.1Semantic versions3.4.1

Version evidence: OSV · GHSA-9v3m-8fp8-mj99

View original version evidence (0 explicit versions)
Affected rangeRecorded fix
Earlier releases before 5.3.0Ecosystem versions5.3.0

Version evidence: OSV · GHSA-9v3m-8fp8-mj99

View original version evidence (46 explicit versions)
Affected rangeRecorded fix
From 3.0.0 before 3.4.1Ecosystem versions3.4.1
From 4.0.0 before 4.3.1Ecosystem versions4.3.1

Version evidence: OSV · GHSA-9v3m-8fp8-mj99

View original version evidence (31 explicit versions)
Affected rangeRecorded fix
From 3.0.0 before 3.4.1Ecosystem versions3.4.1
From 4.0.0 before 4.3.1Ecosystem versions4.3.1

Version evidence: OSV · GHSA-9v3m-8fp8-mj99

View original version evidence (23 explicit versions)

Original source description

Versions of bootstrap prior to 3.4.1 for 3.x and 4.3.1 for 4.x are vulnerable to Cross-Site Scripting (XSS). The data-template attribute of the tooltip and popover plugins lacks input sanitization and may allow attacker to execute arbitrary JavaScript.

Recommendation

For bootstrap 4.x upgrade to 4.3.1 or later. For bootstrap 3.x upgrade to 3.4.1 or later.

References