Apache Airflow Hive Provider Improper Input Validation vulnerability
The advisory, in context
Improper Input Validation vulnerability in the Apache Airflow Hive Provider. This issue affects Apache Airflow Hive Provider versions before 5.1.3.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
Earlier releases before 5.1.3
Fixed in 5.1.3
59 explicitly affected versions
1.0.0, 1.0.0b1, 1.0.0b2, 1.0.0rc1, 1.0.1, 1.0.1rc1, 1.0.2, 1.0.2rc1, 1.0.3, 1.0.3rc1, 2.0.0, 2.0.0rc1, 2.0.0rc2, 2.0.1, 2.0.1rc1, 2.0.1rc2, 2.0.2, 2.0.2rc1, 2.0.3, 2.0.3rc1, 2.1.0, 2.1.0rc1, 2.2.0, 2.2.0rc1, 2.2.0rc2, 2.3.0, 2.3.0rc1, 2.3.1, 2.3.1rc1, 2.3.2, 2.3.2rc1, 2.3.3, 2.3.3rc1, 3.0.0, 3.0.0rc1, 3.0.0rc2, 3.1.0, 3.1.0rc1, 4.0.0, 4.0.0rc1, 4.0.0rc2, 4.0.0rc3, 4.0.1, 4.0.1rc1, 4.1.0, 4.1.0rc1, 4.1.1, 4.1.1rc2, 4.1.1rc3, 5.0.0, 5.0.0rc1, 5.1.0, 5.1.0rc1, 5.1.0rc2, 5.1.1, 5.1.1rc1, 5.1.2, 5.1.2rc1, 5.1.3rc1
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "5.1.3"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"1.0.0",
"1.0.0b1",
"1.0.0b2",
"1.0.0rc1",
"1.0.1",
"1.0.1rc1",
"1.0.2",
"1.0.2rc1",
"1.0.3",
"1.0.3rc1",
"2.0.0",
"2.0.0rc1",
"2.0.0rc2",
"2.0.1",
"2.0.1rc1",
"2.0.1rc2",
"2.0.2",
"2.0.2rc1",
"2.0.3",
"2.0.3rc1",
"2.1.0",
"2.1.0rc1",
"2.2.0",
"2.2.0rc1",
"2.2.0rc2",
"2.3.0",
"2.3.0rc1",
"2.3.1",
"2.3.1rc1",
"2.3.2",
"2.3.2rc1",
"2.3.3",
"2.3.3rc1",
"3.0.0",
"3.0.0rc1",
"3.0.0rc2",
"3.1.0",
"3.1.0rc1",
"4.0.0",
"4.0.0rc1",
"4.0.0rc2",
"4.0.0rc3",
"4.0.1",
"4.0.1rc1",
"4.1.0",
"4.1.0rc1",
"4.1.1",
"4.1.1rc2",
"4.1.1rc3",
"5.0.0",
"5.0.0rc1",
"5.1.0",
"5.1.0rc1",
"5.1.0rc2",
"5.1.1",
"5.1.1rc1",
"5.1.2",
"5.1.2rc1",
"5.1.3rc1"
]
}References
- https://nvd.nist.gov/vuln/detail/CVE-2023-25696
- https://github.com/apache/airflow/pull/29502
- https://github.com/apache/airflow
- https://github.com/pypa/advisory-database/tree/main/vulns/apache-airflow-providers-apache-hive/PYSEC-2026-272.yaml
- https://lists.apache.org/thread/99g0qm56wmgdxmbtdsvhj4rdnxhpzpml
- https://pypi.org/project/apache-airflow-providers-apache-hive