GHSA-9mpf-g3fc-9rgvmedium
FriendsOfSymfony FOSUserBundle denial of service via login form
The advisory, in context
The login form in the FriendsOfSymfony FOSUserBundle bundle before 1.3.3 for Symfony allows remote attackers to cause a denial of service (CPU consumption) via a long password that triggers an expensive hash computation, as demonstrated by a PBKDF2 computation.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
friendsofsymfony/user-bundle Packagist
Ecosystem versions
From 1.2.0 before 1.2.5
Fixed in 1.2.5
5 explicitly affected versions
1.2.0, v1.2.1, v1.2.2, v1.2.3, v1.2.4
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "1.2.0"
},
{
"fixed": "1.2.5"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"1.2.0",
"v1.2.1",
"v1.2.2",
"v1.2.3",
"v1.2.4"
]
}friendsofsymfony/user-bundle Packagist
Ecosystem versions
From 1.3.0 before 1.3.3
Fixed in 1.3.3
3 explicitly affected versions
v1.3.0, v1.3.1, v1.3.2
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "1.3.0"
},
{
"fixed": "1.3.3"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v1.3.0",
"v1.3.1",
"v1.3.2"
]
}