GIVE YOUR AGENT THE EVIDENCE

Set up in your agent.

One prompt to get started. Paste it into your coding agent to connect cve.new through MCP and bring vulnerability context into your workflow.

Your agent needs remote MCP support and access to https://cve.new/mcp.

Read the setup guide

GIVE YOUR AGENT THE EVIDENCE

Investigate in your agent.

Turn this advisory into a focused investigation. Ask your agent to check your project’s versions, explain the evidence, and suggest a compatible fix.

Your agent needs remote MCP support and access to https://cve.new/mcp.

Read the setup guide

GHSA-9jr9-8ff3-m894high8.3

HAX CMS API Lacks Authorization Checks

Check your stack

Summary

The imported advisory is rated high severity. It identifies 2 affected packages; whether you are affected depends on your installed version. It is not listed in the imported CISA KEV data; that does not establish that exploitation has not occurred.

Summary by cve.new · CC BY 4.0

Original source description

Summary

The HAX CMS API endpoints do not perform authorization checks when interacting with a resource. Both the JS and PHP versions of the CMS do not verify that a user has permission to interact with a resource before performing a given operation.

Details

The API endpoints within the HAX CMS application check if a user is authenticated, but don't check for authorization before performing an operation.

Affected Resources

Note: This may not include all affected endpoints within the application.

Impact

An authenticated attacker can make requests to interact with other users' sites. This can be used to enumerate, modify, and delete other users' sites and nodes.

Additionally, an authenticated attacker can use the 'getConfig' endpoint to pull the application's configuration, which may store cleartext credentials.

PoC - /deleteNode

  1. Browse to the 'site.json' file for a target site, and note the ID of the item to delete.

image

  1. Make a POST request to the 'deleteNode' endpoint with a valid JWT and the target object ID.

image

Site before editing:

image

Site after editing:

image

Affected packages

Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.

Semantic versions

Earlier releases before 11.0.14

Fixed in 11.0.14

View affected-version evidence
{
  "ranges": [
    {
      "events": [
        {
          "introduced": "0"
        },
        {
          "fixed": "11.0.14"
        }
      ],
      "type": "SEMVER"
    }
  ],
  "versions": []
}
Ecosystem versions

Earlier releases before 11.0.14

Fixed in 11.0.14

17 explicitly affected versions

0.0.1, 0.1.0, 0.11.0, 0.12.0, 0.12.1, 0.12.2, 0.12.3, 0.2.0, 0.3.0, 0.4.0, 0.5.0, 0.6.0, 0.7.0, 0.8.0, 0.8.1, 0.8.2, 0.9.0

View affected-version evidence
{
  "ranges": [
    {
      "events": [
        {
          "introduced": "0"
        },
        {
          "fixed": "11.0.14"
        }
      ],
      "type": "ECOSYSTEM"
    }
  ],
  "versions": [
    "0.0.1",
    "0.1.0",
    "0.11.0",
    "0.12.0",
    "0.12.1",
    "0.12.2",
    "0.12.3",
    "0.2.0",
    "0.3.0",
    "0.4.0",
    "0.5.0",
    "0.6.0",
    "0.7.0",
    "0.8.0",
    "0.8.1",
    "0.8.2",
    "0.9.0"
  ]
}

References