GHSA-9jm4-rg99-566chigh7.5
phpBB Server-Side Request Forgery (SSRF)
The advisory, in context
phpBB version 3.2.0 is vulnerable to SSRF in the Remote Avatar function resulting allowing an attacker to perform port scanning, requesting internal content and potentially attacking such internal services via the web application.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
phpbb/phpbb Packagist
Ecosystem versions
From 3.2.0 before 3.2.1
Fixed in 3.2.1
2 explicitly affected versions
3.2.0, 3.2.1-RC1
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "3.2.0"
},
{
"fixed": "3.2.1"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"3.2.0",
"3.2.1-RC1"
]
}