laravel-auth0 SDK Vulnerable to Brute Force Authentication Tags of CookieStore Sessions
The advisory, in context
Overview Session cookies of applications using the laravel-auth0 SDK configured with CookieStore have authentication tags that can be brute forced, which may result in unauthorized access.
Am I Affected? You are affected by this vulnerability if you meet the following pre-conditions:
- Applications using laravel-auth0 SDK with version <=7.16.0
- laravel-auth0 SDK uses the Auth0-PHP SDK with version 8.0.0-BETA1 or higher and below 8.14.0.
- Session storage configured with CookieStore.
Fix Upgrade Auth0/laravel-auth0 to v7.17.0. As an additional precautionary measure, we recommend rotating your cookie encryption keys. Note that once updated, any previous session cookies will be rejected.
Acknowledgement Okta would like to thank Félix Charette for discovering this vulnerability.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
Earlier releases before 7.17.0
Fixed in 7.17.0
76 explicitly affected versions
1.0.3, 1.0.4, 1.0.5, 1.0.6, 1.0.7, 1.0.8, 2.0.0, 2.1.0, 2.1.1, 2.1.2, 2.1.3, 2.1.4, 2.2.0, 2.2.1, 2.3.0, 2.3.1, 2.3.2, 3.0.0, 3.0.1, 3.0.2, 3.0.3, 3.1.0, 3.2.0, 3.2.1, 4.0.0, 4.0.1, 4.0.2, 4.0.3, 4.0.4, 4.0.5, 4.0.6, 4.0.7, 4.0.8, 5.0.0, 5.0.1, 5.0.2, 5.1.0, 5.2.0, 5.3.0, 5.3.1, 5.4.0, 6.0.0, 6.0.1, 6.1.0, 6.2.0, 6.3.0, 6.4.0, 6.4.1, 6.5.0, 7.0.0, 7.0.0-BETA1, 7.0.0-BETA2, 7.0.1, 7.1.0, 7.10.0, 7.10.1, 7.11.0, 7.12.0, 7.13.0, 7.14.0, 7.15.0, 7.16.0, 7.2.0, 7.2.1, 7.2.2, 7.3.0, 7.4.0, 7.5.0, 7.5.1, 7.5.2, 7.6.0, 7.7.0, 7.8.0, 7.8.1, 7.9.0, 7.9.1
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "7.17.0"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"1.0.3",
"1.0.4",
"1.0.5",
"1.0.6",
"1.0.7",
"1.0.8",
"2.0.0",
"2.1.0",
"2.1.1",
"2.1.2",
"2.1.3",
"2.1.4",
"2.2.0",
"2.2.1",
"2.3.0",
"2.3.1",
"2.3.2",
"3.0.0",
"3.0.1",
"3.0.2",
"3.0.3",
"3.1.0",
"3.2.0",
"3.2.1",
"4.0.0",
"4.0.1",
"4.0.2",
"4.0.3",
"4.0.4",
"4.0.5",
"4.0.6",
"4.0.7",
"4.0.8",
"5.0.0",
"5.0.1",
"5.0.2",
"5.1.0",
"5.2.0",
"5.3.0",
"5.3.1",
"5.4.0",
"6.0.0",
"6.0.1",
"6.1.0",
"6.2.0",
"6.3.0",
"6.4.0",
"6.4.1",
"6.5.0",
"7.0.0",
"7.0.0-BETA1",
"7.0.0-BETA2",
"7.0.1",
"7.1.0",
"7.10.0",
"7.10.1",
"7.11.0",
"7.12.0",
"7.13.0",
"7.14.0",
"7.15.0",
"7.16.0",
"7.2.0",
"7.2.1",
"7.2.2",
"7.3.0",
"7.4.0",
"7.5.0",
"7.5.1",
"7.5.2",
"7.6.0",
"7.7.0",
"7.8.0",
"7.8.1",
"7.9.0",
"7.9.1"
]
}References
- https://github.com/auth0/laravel-auth0/security/advisories/GHSA-9fwj-9mjf-rhj3
- https://nvd.nist.gov/vuln/detail/CVE-2025-47275
- https://github.com/auth0/laravel-auth0/commit/be2c59adb476c49945dcc55741a54c7a68c1741d
- https://github.com/auth0/laravel-auth0
- https://github.com/auth0/laravel-auth0/releases/tag/7.17.0