Mautic vulnerable to Relative Path Traversal / Arbitrary File Deletion due to GrapesJS builder
The advisory, in context
Impact
Prior to the patched version, logged in users of Mautic are vulnerable to Relative Path Traversal/Arbitrary File Deletion. Regardless of the level of access the Mautic user had, they could delete files other than those in the media folders such as system files, libraries or other important files.
This vulnerability exists in the implementation of the GrapesJS builder in Mautic.
Patches
Update to 4.4.12 or 5.0.4.
Workarounds
No
References
- https://cwe.mitre.org/data/definitions/23.html
- https://cwe.mitre.org/data/definitions/22.html
- https://attack.mitre.org/techniques/T1630/002/
For more information
If you have any questions or comments about this advisory:
Email us at security@mautic.org
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
From 3.3.0 before 4.4.12
Fixed in 4.4.12
39 explicitly affected versions
3.3.0, 3.3.1, 3.3.2, 3.3.2-rc, 3.3.3, 3.3.3-rc, 3.3.4, 3.3.5, 4.0.0, 4.0.0-alpha1, 4.0.0-beta, 4.0.0-rc, 4.0.1, 4.0.2, 4.1.0, 4.1.1, 4.1.2, 4.2.0, 4.2.0-rc, 4.2.0-rc1, 4.2.1, 4.2.2, 4.3.0, 4.3.0-beta, 4.3.0-rc, 4.3.1, 4.4.0, 4.4.0-beta, 4.4.1, 4.4.10, 4.4.11, 4.4.2, 4.4.3, 4.4.4, 4.4.5, 4.4.6, 4.4.7, 4.4.8, 4.4.9
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "3.3.0"
},
{
"fixed": "4.4.12"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"3.3.0",
"3.3.1",
"3.3.2",
"3.3.2-rc",
"3.3.3",
"3.3.3-rc",
"3.3.4",
"3.3.5",
"4.0.0",
"4.0.0-alpha1",
"4.0.0-beta",
"4.0.0-rc",
"4.0.1",
"4.0.2",
"4.1.0",
"4.1.1",
"4.1.2",
"4.2.0",
"4.2.0-rc",
"4.2.0-rc1",
"4.2.1",
"4.2.2",
"4.3.0",
"4.3.0-beta",
"4.3.0-rc",
"4.3.1",
"4.4.0",
"4.4.0-beta",
"4.4.1",
"4.4.10",
"4.4.11",
"4.4.2",
"4.4.3",
"4.4.4",
"4.4.5",
"4.4.6",
"4.4.7",
"4.4.8",
"4.4.9"
]
}From 5.0.0-alpha before 5.0.4
Fixed in 5.0.4
10 explicitly affected versions
5.0.0, 5.0.0-alpha, 5.0.0-alpha1, 5.0.0-beta1, 5.0.0-beta2, 5.0.0-rc1, 5.0.0-rc2, 5.0.1, 5.0.2, 5.0.3
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "5.0.0-alpha"
},
{
"fixed": "5.0.4"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"5.0.0",
"5.0.0-alpha",
"5.0.0-alpha1",
"5.0.0-beta1",
"5.0.0-beta2",
"5.0.0-rc1",
"5.0.0-rc2",
"5.0.1",
"5.0.2",
"5.0.3"
]
}References
- https://github.com/mautic/mautic/security/advisories/GHSA-9fcx-cv56-w58p
- https://nvd.nist.gov/vuln/detail/CVE-2021-27916
- https://github.com/mautic/mautic/commit/546045ff9c74dd8b3dac36c4ab3674380262c65a
- https://github.com/mautic/mautic/commit/95e8df3ae6730c725f1848d70e7992da369518f3
- https://github.com/mautic/mautic