GHSA-99fg-2h75-m92hmedium6.1
Spipu HTML2PDF vulnerable to cross-site scripting
The advisory, in context
Cross Site Scripting vulnerability in Spipu HTML2PDF before v.5.2.8 allows a remote attacker to execute arbitrary code via a crafted script to the forms.php.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
spipu/html2pdf Packagist
Ecosystem versions
Earlier releases before 5.2.8
Fixed in 5.2.8
16 explicitly affected versions
v4.4.0, v4.5.0, v4.5.1, v4.6.0, v4.6.1, v5.0.0, v5.0.1, v5.1.0, v5.2.0, v5.2.1, v5.2.2, v5.2.3, v5.2.4, v5.2.5, v5.2.6, v5.2.7
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "5.2.8"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v4.4.0",
"v4.5.0",
"v4.5.1",
"v4.6.0",
"v4.6.1",
"v5.0.0",
"v5.0.1",
"v5.1.0",
"v5.2.0",
"v5.2.1",
"v5.2.2",
"v5.2.3",
"v5.2.4",
"v5.2.5",
"v5.2.6",
"v5.2.7"
]
}References
- https://nvd.nist.gov/vuln/detail/CVE-2023-39062
- https://github.com/spipu/html2pdf/commit/92afd81823d62ad95eb9d034858311bb63aeb4ac
- https://github.com/afine-com/CVE-2023-39062
- https://github.com/sectroyer/CVEs/tree/main/CVE-2023-39062
- https://github.com/spipu/html2pdf
- https://github.com/spipu/html2pdf/blob/92afd81823d62ad95eb9d034858311bb63aeb4ac/CHANGELOG.md