ezsystems/ezplatform-admin-ui has an XSS vulnerability in Cancel/Reschedule future publication modal
The advisory, in context
Impact
This security advisory resolves an XSS vulnerability in image asset names, content language names and future publishing in the back office of the DXP. Back office access and varying levels of editing and management permissions are required to exploit this vulnerability. This typically means Editor or Administrator role, or similar. Injected XSS is persistent and may in some cases be reflected in the front office, possibly affecting end users. The fixes ensure XSS is escaped, and any existing injected XSS is rendered harmless.
Patches
See "Patched versions".
Workarounds
None.
References
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
From 2.3.0 before 2.3.39
Fixed in 2.3.39
39 explicitly affected versions
v2.3.0, v2.3.1, v2.3.10, v2.3.11, v2.3.12, v2.3.13, v2.3.14, v2.3.15, v2.3.16, v2.3.17, v2.3.18, v2.3.19, v2.3.2, v2.3.20, v2.3.21, v2.3.22, v2.3.23, v2.3.24, v2.3.25, v2.3.26, v2.3.27, v2.3.28, v2.3.29, v2.3.3, v2.3.30, v2.3.31, v2.3.32, v2.3.33, v2.3.34, v2.3.35, v2.3.36, v2.3.37, v2.3.38, v2.3.4, v2.3.5, v2.3.6, v2.3.7, v2.3.8, v2.3.9
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "2.3.0"
},
{
"fixed": "2.3.39"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v2.3.0",
"v2.3.1",
"v2.3.10",
"v2.3.11",
"v2.3.12",
"v2.3.13",
"v2.3.14",
"v2.3.15",
"v2.3.16",
"v2.3.17",
"v2.3.18",
"v2.3.19",
"v2.3.2",
"v2.3.20",
"v2.3.21",
"v2.3.22",
"v2.3.23",
"v2.3.24",
"v2.3.25",
"v2.3.26",
"v2.3.27",
"v2.3.28",
"v2.3.29",
"v2.3.3",
"v2.3.30",
"v2.3.31",
"v2.3.32",
"v2.3.33",
"v2.3.34",
"v2.3.35",
"v2.3.36",
"v2.3.37",
"v2.3.38",
"v2.3.4",
"v2.3.5",
"v2.3.6",
"v2.3.7",
"v2.3.8",
"v2.3.9"
]
}