GHSA-96hw-v598-jvghcritical9.8
Cobbler vulnerable to arbitrary code execution
The advisory, in context
Cobbler version up to 2.8.2 is vulnerable to a command injection vulnerability in the "add repo" component resulting in arbitrary code execution as root user.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
cobbler PyPI
Ecosystem versions
Earlier releases before 3.0.0
Fixed in 3.0.0
1 explicitly affected versions
0.6.3-2
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "3.0.0"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"0.6.3-2"
]
}References
- https://nvd.nist.gov/vuln/detail/CVE-2017-1000469
- https://github.com/cobbler/cobbler/issues/1845
- https://github.com/cobbler/cobbler/commit/4b20397425a5d42a2d8927233654f4d7435bd4c2
- https://github.com/cobbler/cobbler
- https://github.com/pypa/advisory-database/tree/main/vulns/cobbler/PYSEC-2026-314.yaml
- https://pypi.org/project/cobbler