GHSA-9645-6g72-2pv8high
phpMyAdmin unsafely handles temporary files
The advisory, in context
libraries/File.class.php in phpMyAdmin 2.11.x before 2.11.10 uses predictable filenames for temporary files, which has unknown impact and attack vectors.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
phpmyadmin/phpmyadmin Packagist
Ecosystem versions
From 2.11.0 before 2.11.10
Fixed in 2.11.10
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "2.11.0"
},
{
"fixed": "2.11.10"
}
],
"type": "ECOSYSTEM"
}
],
"versions": []
}References
- https://nvd.nist.gov/vuln/detail/CVE-2008-7252
- https://github.com/phpmyadmin/composer
- https://web.archive.org/web/20100613071447/http://secunia.com/advisories/38211
- https://web.archive.org/web/20100613071509/http://secunia.com/advisories/39503
- https://web.archive.org/web/20110729050522/http://www.securityfocus.com/bid/37826
- http://lists.opensuse.org/opensuse-security-announce/2010-01/msg00007.html
- http://phpmyadmin.svn.sourceforge.net/viewvc/phpmyadmin/branches/QA_2_11/phpMyAdmin/libraries/File.class.php?r1=11528&r2=11527&pathrev=11528
- http://phpmyadmin.svn.sourceforge.net/viewvc/phpmyadmin?view=rev&revision=11528
- http://www.debian.org/security/2010/dsa-2034
- http://www.phpmyadmin.net/home_page/security/PMASA-2010-2.php