GHSA-94c2-g68f-9r98medium
Typo3 API XSS Vulnerability
The advisory, in context
Incomplete blacklist vulnerability in the t3lib_div::quoteJSvalue API function in TYPO3 4.5.x before 4.5.19, 4.6.x before 4.6.12 and 4.7.x before 4.7.4 allows remote attackers to conduct cross-site scripting (XSS) attacks via certain HTML5 JavaScript events.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
typo3/cms Packagist
Ecosystem versions
From 4.5 before 4.5.19
Fixed in 4.5.19
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "4.5"
},
{
"fixed": "4.5.19"
}
],
"type": "ECOSYSTEM"
}
],
"versions": []
}typo3/cms Packagist
Ecosystem versions
From 4.6 before 4.6.12
Fixed in 4.6.12
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "4.6"
},
{
"fixed": "4.6.12"
}
],
"type": "ECOSYSTEM"
}
],
"versions": []
}typo3/cms Packagist
Ecosystem versions
From 4.7 before 4.7.4
Fixed in 4.7.4
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "4.7"
},
{
"fixed": "4.7.4"
}
],
"type": "ECOSYSTEM"
}
],
"versions": []
}